elasticsearch throws ElasticsearchIllegalStateException: node is not configured to store local location


(Nish) #1

I am turning on a single node instance (master+data) and trying to use
logstash and I see this error:

log4j, [2014-05-08T16:11:05.571] ERROR:
org.elasticsearch.gateway.local.state.meta:
[logstash-ip-10-169-36-251-5993-4082] failed to read local state, exiting...
org.elasticsearch.ElasticsearchIllegalStateException: node is not
configured to store local location

This is my elasticsearch.yml:

cluster.name: elasticsearchtest
node.name: "node1"
node.master: true
node.data: true
index.number_of_replicas: 0

Any idea ?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/6d2df641-8afb-4d9d-831f-7bf1ab801d8f%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Nish) #2

I get the error while running logstash
I tried 127.0.0.1 , "localhost" , and it still throws same
error ; the weird thing is that if I use elasticsearch in the input{} block
; logstash is able to read from it.

On Thursday, May 8, 2014 12:32:35 PM UTC-4, Nish wrote:

I am turning on a single node instance (master+data) and trying to use
logstash and I see this error:

log4j, [2014-05-08T16:11:05.571] ERROR:
org.elasticsearch.gateway.local.state.meta:
[logstash-ip-10-169-36-251-5993-4082] failed to read local state, exiting...
org.elasticsearch.ElasticsearchIllegalStateException: node is not
configured to store local location

This is my elasticsearch.yml:

cluster.name: elasticsearchtest
node.name: "node1"
node.master: true
node.data: true
index.number_of_replicas: 0

Any idea ?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/2f4326cb-6fa2-406f-8e4e-9c2d3264917b%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Sumit Gupta) #3

Hi,

Comment node.master=true
I think it should work.

Thanks,
Sumit G


(system) #4