Elasticsearch transform index using scripted fields

I am using Elasic Cloud v7.5. I created two scripted fields. I am able to search and aggregate on the fields. I tried to transform to new index using the aggregate of scripted fields but the values are coming as zero in destination index. I used Create Transform UI in Kibana and tried to create the transform index. The destination index does not considering scripted fields.

Do we need to update the query in Advanced Pivot Editor?

To pin down your issue, can you explain if the scripted fields you created refer to Kibana's scripted fields or Elasticsearch's script fields or even another feature? Unfortunately both are unsupported by transforms, but you can use scripts in aggregations like scripted metric.

If you're able to post some sample data and the configurations you're trying to run, we may be able to help out a bit more in working towards a solution.

Thanks for the reply. While doing transform, I used scripts in aggregations and it solved the problem.

1 Like