Elasticsearch upgrade from 7.6 to 7.13

S.O: Ubuntu 18.04
ES: 7.6.1 (Before upgrade)

I tried to upgrade my ElasticStack with 3 nodes (1 master, 2 slave).

Following the Guide. And all of those steps are only on master.
here my steps:

curl -XPUT -u elastic:changeme "localhost:9200/_cluster/settings?pretty" -H 'Content-Type: application/json' -d'
  "persistent": {
    "cluster.routing.allocation.enable": "primaries"
curl -XPOST -u elastic:changeme "localhost:9200/_flush/synced?pretty"
service elasticsearch stop
apt-get update && apt-get install elasticsearch

Eventually this asked for override my elasticsearch.yml file, I pressed "N".
And then tried to start elastic but got error:

[2021-06-16T13:06:56,069][INFO ][o.e.i.g.DatabaseRegistry ] [master] initialized database registry, using geoip-databases directory [/tmp/elasticsearch-1576930118492589462/geoip-databases/V3a78v1XTUWzHmDr52dZBA]
[2021-06-16T13:06:57,054][INFO ][o.e.t.NettyAllocator     ] [master] creating NettyAllocator with the following configs: [name=unpooled, suggested_max_allocation_size=1mb, factors={es.unsafe.use_unpooled_allocator=null, g1gc_enabled=true, g1gc_region_size=4mb, heap_size=1gb}]
[2021-06-16T13:06:57,168][INFO ][o.e.d.DiscoveryModule    ] [master] using discovery type [zen] and seed hosts providers [settings]
[2021-06-16T13:06:57,911][INFO ][o.e.g.DanglingIndicesState] [master] gateway.auto_import_dangling_indices is disabled, dangling indices will not be automatically detected or imported and must be managed manually
[2021-06-16T13:06:58,707][INFO ][o.e.n.Node               ] [master] initialized
[2021-06-16T13:06:58,709][INFO ][o.e.n.Node               ] [master] starting ...
[2021-06-16T13:06:58,854][INFO ][o.e.x.s.c.f.PersistentCache] [master] persistent cache index loaded
[2021-06-16T13:06:59,078][INFO ][o.e.t.TransportService   ] [master] publish_address {}, bound_addresses {}, {[::1]:9300}, {}
[2021-06-16T13:07:00,592][INFO ][o.e.b.BootstrapChecks    ] [master] bound or publishing to a non-loopback address, enforcing bootstrap checks
[2021-06-16T13:07:00,601][ERROR][o.e.b.Bootstrap          ] [master] node validation exception
[1] bootstrap checks failed. You must address the points described in the following [1] lines before starting Elasticsearch.
bootstrap check failure [1] of [1]: memory locking requested for elasticsearch process but memory is not locked
[2021-06-16T13:07:00,632][INFO ][o.e.n.Node               ] [master] stopping ...
[2021-06-16T13:07:00,718][INFO ][o.e.n.Node               ] [master] stopped
[2021-06-16T13:07:00,723][INFO ][o.e.n.Node               ] [master] closing ...
[2021-06-16T13:07:00,769][INFO ][o.e.n.Node               ] [master] closed
[2021-06-16T13:07:00,771][INFO ][o.e.x.m.p.NativeController] [master] Native controller process has stopped - no new native processes can be started

This is elasticsearch.yml file

cluster.name: cluster
node.name: master
reindex.remote.whitelist: ''
node.master: true
#node.data: true
path.data: /var/lib/elasticsearch
path.logs: /var/log/elasticsearch
network.host: ["localhost", ""]
#discovery.seed_host: ["", "", ""]
cluster.initial_master_nodes: ["", "", ""]
#discovery.zen.ping.unicast.hosts: ["", "", ""]
discovery.seed_hosts: ["", "", ""]
bootstrap.memory_lock: true
xpack.security.enabled: true
xpack.security.transport.ssl.enabled: true
xpack.security.transport.ssl.verification_mode: certificate
xpack.security.transport.ssl.keystore.path: elastic-certificates.p12
xpack.security.transport.ssl.truststore.path: elastic-certificates.p12

script.painless.regex.enabled: true

And file /etc/default/elasticsearch I have MAX_LOCKED_MEMORY=infinity



$ systemctl edit elasticsearch

Write line



$ systemctl daemon-reload 
$ systemctl restart elasticsearch
1 Like

Thanks for sharing your solution!

Also please note that there is no such thing as a slave in Elasticsearch :slight_smile:

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.