ElasticSearch using EC2 and VPC - Cluster doesn't form in any way


(Yoav Zuri) #1

Hello,

I need to configure ElasticSearch cluster in EC2 VPC and it seems like
something's blocking me from doing so.

My configuation:

elastic1 - 172.16.1.20 - config file:

node.name: elastic1
cluster.name: logstash
cloud:
aws:
access_key: AKIXXXXXXXXXXXX
secret_key: 6gGUXXXXXXXXXXXXXXXXXXXXXXXXXXX
region: "us-east-1"

discovery.zen.ping.multicast.enabled: false
discovery.type: ec2

elastic2 - 172.16.1.21 - config file:

node.name: elastic2
cluster.name: logstash
cloud:
aws:
access_key: AKIXXXXXXXXXXXX
secret_key: 6gGUXXXXXXXXXXXXXXXXXXXXXXXXXXX
region: "us-east-1"

discovery.zen.ping.multicast.enabled: false
discovery.type: ec2

My VPC has route for 172.16.1.0/24 to local
Security Group is open to any traffic from the same SG.

Telnet works both ways for 9200 & 9300

Log example:
[2014-03-02 09:44:12,139][TRACE][discovery.ec2 ] [elastic2]
adding i-b7bb9796, address 172.16.1.21, transport_address
inet[/172.16.1.21:9300]
[2014-03-02 09:44:12,140][TRACE][discovery.ec2 ] [elastic2]
adding i-02bb9723, address 172.16.1.20, transport_address
inet[/172.16.1.20:9300]

But it doesn't work in any way.

[root@elastic1 elasticsearch]# curl -s
http://localhost:9200/_cluster/health?pretty=true
{
"cluster_name" : "visadd",
"status" : "green",
"timed_out" : false,
"number_of_nodes" : 1,
"number_of_data_nodes" : 1,
"active_primary_shards" : 0,
"active_shards" : 0,
"relocating_shards" : 0,
"initializing_shards" : 0,
"unassigned_shards" : 0
}

elastic1 nmap -p- scan of 172.16.1.21:
22/tcp open ssh
9200/tcp open wap-wsp
9300/tcp open vrace

Any help will be appreciated!

Best Regards,
Yoav Zuri

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/34f85e82-e316-4908-805f-c336f3ba33bb%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #2