Trying to set up multi-node cluster on AWS EC2

Hi, I'm sure I'm missing something basic here but I'm not sure what it is.

I have a single-node cluster currently running on an Amazon EC2 instance that I am trying to expand to a three-node cluster. I have two more EC2 instances running with the same configuration with Elasticsearch installed and running. All are in the same security group and the security group is completely open to itself. I've confirmed that they can see each other by using curl to check each from each other.

The problem is I can't get the Elasticsearch instances to see each other and they won't join as a cluster. I do have discover-ec2 installed. Here's what my config looks like: my-logging my-logging-1 /var/lib/elasticsearch
path.logs: /var/log/elasticsearch ""
http.port: 9200 ["", "", ""]
discovery.zen.hosts_provider: ec2
transport.tcp.port: 9300
xpack.license.self_generated.type: basic

The only difference in the config between the three instances is the and

I've tried using ports 9200 and 9300 in the unicast.hosts list and using both ip and public addresses.

I'm sure I'm missing something obvious. The only other thing I can think of is that I have x-pack installed and I'm wondering if the security is throwing me off. I've tried adding user:password@ to the start of the addresses but that didn't seem to work either.

Any ideas? Thanks.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.