ElasticSearch v7 docker container not starting on RHEL 8.8

When we try to run elasticsearch v7.17.0 or v7.17.12, we are facing an error to start the container. It fails with "2023-08-29T12:34:54.499254418+05:30 stderr F chroot: cannot change root directory to '/': Operation not permitted". One change we know of rhel 8.8 is, it is using podman 4.

This was working fine on RHEL v8.4 which was internally using podman3.

When we tried to run the latest elasticsearch container v8.9.1 on RHEL v8.8, this problem is not coming.

Is anyone facing same problem? Or anyone knows any solution for fixing this on v7 elasticsearch containers?


How are you running the container? Through CLI or podman-compose.yml file? And are you mounting or binding a volume for the elasticsearch.yml file ?

If you are mounting or binding a volume for the elasticsearch.yml file, it could be that selinux is blocking the file from being read. I ran into that issue and it was selinux that caused the problem.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.