Elasticsearch version incompatible with this version of Curator


Im trying to delet indices with Curator and get this error:

root@elk:~# /usr/bin/curator --config /etc/curator/config.yml /etc/curator/action.yml
2019-02-28 07:45:21,553 INFO      Preparing Action ID: 1, "close"
2019-02-28 07:45:21,559 ERROR     Elasticsearch version 6.6.1 incompatible with this version of Curator (5.2.0)
Traceback (most recent call last):
  File "/usr/bin/curator", line 11, in <module>
load_entry_point('elasticsearch-curator==5.2.0', 'console_scripts', 'curator')()
  File "/usr/lib/python2.7/dist-packages/click/core.py", line 759, in __call__
return self.main(*args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/click/core.py", line 714, in main
rv = self.invoke(ctx)
  File "/usr/lib/python2.7/dist-packages/click/core.py", line 951, in invoke
return ctx.invoke(self.callback, **ctx.params)
  File "/usr/lib/python2.7/dist-packages/click/core.py", line 552, in invoke
return callback(*args, **kwargs)
  File "/usr/lib/python2.7/dist-packages/curator/cli.py", line 211, in cli
run(config, action_file, dry_run)
  File "/usr/lib/python2.7/dist-packages/curator/cli.py", line 158, in run
client = get_client(**client_args)
  File "/usr/lib/python2.7/dist-packages/curator/utils.py", line 800, in get_client
'Error: {0}'.format(e)
elasticsearch.exceptions.ElasticsearchException: Unable to create client connection to Elasticsearch.  Error: Elasticsearch version 6.6.1 incompatible with this vers                                                                        ion of Curator (5.2.0)

At first i've installed Curator with commands:

yum install elasticsearch-curator
apt update && apt install elasticsearch-curator

After the first error I've tried to updated Curator with:

pip install -U elasticsearch-curator

Now if i use curator --version, it show version 5.6.0. But i still got same error.

What am i doing wrong?

Think im fixed it

At first i deleted old version with sudo apt-get purge --auto-remove elasticsearch-curator

And now i got this output

root@elk:/etc/curator# curator --config /etc/curator/config.yml /etc/curator/action.yml --dry-run
2019-02-28 11:54:47,952 INFO      Preparing Action ID: 1, "delete_indices"
2019-02-28 11:54:47,957 INFO      Trying Action ID: 1, "delete_indices": Delete logstash indices older than 30 days.
2019-02-28 11:54:49,106 INFO      Skipping action "delete_indices" due to empty list: <class 'curator.exceptions.NoIndices'>
2019-02-28 11:54:49,106 INFO      Action ID: 1, "delete_indices" completed.
2019-02-28 11:54:49,106 INFO      Job completed.
1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.