Elasticsearch won't start first use - 8.1.0

After downloading Elasticsearch from zip to windows. run bin\Elasticsearch.bat getting Error:
skipping security auto configuration because the configuration file [C:\Program Files\Elasticsearch-8.1.0\bin\Elasticsearch\Elasticsearch.yml] is missing or is not a regular file.

The Elasticsearch.yml file is located in the config folder


That's looking weird.
Could you open an issue with your findings (all the exact steps you followed)?

I'd try to move the Elasticsearch-8.1.0 to another dir like: c:\Elasticsearch-8.1.0. I have seen in the past that having spaces in the dir name could lead to issues.

Hi David,
Thank you for the quick reply.
I try everything possible.
I have follow the website instructions:

  1. Download the Elasticsearch 8.1.0 Windows zip file from the Elasticsearch download page.
  2. Extract the contents of the zip file to a directory on your computer, to C:\Elasticsearch-8.1.0 (No spaces)
  3. Open a command prompt as an Administrator and navigate to the directory that contains the extracted files.

cd C:\Elasticsearch-8.1.0

  1. Start Elasticsearch:


getting this Error:

skipping security auto configuration because the configuration file [C:\Elasticsearch-8.1.0\bin\Elasticsearch\Elasticsearch.yml] is missing or is not a regular file.

Thank you,

So please open an issue.

Hi david,

As you said I opened an issue, but they closed it immediately .
Their answer is attached.

Thanks very much for your interest in Elasticsearch.

This appears to be a user question, and we'd like to direct these kinds of things to the forums. If you can stop by there, we'd appreciate it. This allows us to use GitHub for verified bug reports, feature requests, and pull requests.

There's an active community in the forums that should be able to help get an answer to your question. As such, I hope you don't mind that I close this.

‫בתאריך יום ג׳, 15 במרץ 2022 ב-21:47 מאת ‪David Pilato via Discuss the Elastic Stack‬‏ <‪elastic@discoursemail.com‬‏>:‬

Could you share the link to the issue?


This is not an error, this is logged as an informational message. The actual issue is that the Elasticsearch.yml seems to be missing.

Please share the entire output from starting Elasticsearch, not just this line. Also please share the output of running dir C:\elasticsearch-8.1.0\config Just after you download and unzip the archive

The problem is the program looks for Elasticsearch.yml in the wrong folder -> c:\Elasticsearch-8.1.0\bin\Elasticsearch\Elasticsearch.yml instead of C:\Elasticsearch-8.1.0\config

The Error:

The config dir:

‫בתאריך שבת, 19 במרץ 2022 ב-21:43 מאת ‪Ioannis Kakavas via Discuss the Elastic Stack‬‏ <‪elastic@discoursemail.com‬‏>:‬

Thanks you for the additional information, this does look like a bug. I’ll try and reproduce this and I’ll open an issue.

I’m the meantime, can you try to

cd c:\Elasticsearch-8.1.0\bin

And start elastisearch from there with


and see if that works ?


‫בתאריך יום א׳, 20 במרץ 2022 ב-9:03 מאת ‪Ioannis Kakavas via Discuss the Elastic Stack‬‏ <‪elastic@discoursemail.com‬‏>:‬

Can you check whether you the environment variable ES_PATH_CONF is set in your terminal?

Two different parts of the startup process (security auto configuration & JVM options parsing) are both trying to read files relative to the bin directory, so it looks like you (or some other process) might have configured Elasticsearch to look there.

Of note, the path in the error message changed when you ran it from the bin directory.
It looks like Elasticsearch has been configured to use bin/elasticsearch as the config directory (relative to the current working directory).

When nothing worked I tried to add it.
like this:

For the archive distributions, the config directory location defaults to $ES_HOME/config. The location of the config directory can be changed via the ES_PATH_CONF environment variable as follows:

ES_PATH_CONF=/path/to/my/config ./bin/elasticsearch

but after it didn't i removed it.

‫בתאריך יום ב׳, 21 במרץ 2022 ב-3:39 מאת ‪Tim Vernum via Discuss the Elastic Stack‬‏ <‪elastic@discoursemail.com‬‏>:‬

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.