ELK migration 6.8 to 7.3 lost daily index creation

Prior to migration to 7.3, daily indexes were auto created. After migration to 7.3, my first week on 7.3 is in a single index. My logstash output file :

output {
elasticsearch {
hosts => ["logstash-2.xxx.xxx:9200"]
sniffing => true
manage_template => true
index => "logstash-%{+YYYY.MM.dd}"
The index name now includes id and is
From kibana management, the provided name indicates:
"provided_name": "<logstash-{now/d}-000001>"
instead of previous 6.8 entries like:
"provided_name": "logstash-2019.08.06"

Trying to find where the default settings are to config that other than the logstash output file that I indicated above.

solved it - at least for now with following in my output file:
ilm_enabled => false

I thought ilm was introduced in 6.6 and would have seen issues then or at 6.8 but this only came up when starting 7.3. Interested if anyone knows of something I would need to have configured differently for the 6.8 to 7.3 migration. Outside of that, I have my answer for now.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.