Unable to create index per day

Hi, my output config is:
output {
elasticsearch {
hosts => ["localhost"]
manage_template => true
index => "logstash-%{+YYYY.MM.dd}"
}
}
It creates a index like "logstash-2019.10.14-000001" and doesn't create new index per day.
what is the -000001? and why it doesn't create new index per day?
I didn't set any Rollup job and I just wanna have index per day.
I use elk container with logstash and elasticsearch version 7.4.0
Thanx

Does setting the 'ilm_enabled => false' option help?

I've added the 'ilm_enabled => false' and now it's ok. thanx.
but does it disable the ' Index Lifecycle Policies' and 'Rollup Jobs' in Kibana or they are not related at all ?

I do not think it will affect what you have configured in Kibana but I cannot say for certain.

I had this same issue - (no new indexes were being created with the "logstash-%{+YYYY.MM.dd}" pattern until I disabled the "ilm_enabled" setting. There was nothing in the logstash or elasticsearch logs telling me why my index wasnt created. This seems like a bug or is it just something that needs to be better documented?

This was with version 7.4.0 for elastic, kibana, and logstash.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.