Embed dashboard using reverse proxy - Incorrect HTTP method for uri


I'm using nginx as a reverse proxy with the following configuration:

 server {
     listen       4443 ssl;
	 server_name localhost;	 
	 ssl_certificate /etc/nginx/ssl/nginx.crt;
     ssl_certificate_key /etc/nginx/ssl/nginx.key;
	 ssl_session_cache    shared:SSL:1m;
	 ssl_session_timeout 5m;
	 ssl_ciphers  HIGH:!aNULL:!MD5;
	 ssl_prefer_server_ciphers on;

     location / {		
        proxy_set_header  Host $host;
        proxy_set_header  X-Real-IP $remote_addr;
        proxy_set_header  X-Forwarded-For $proxy_add_x_forwarded_for;
        proxy_set_header  Authorization "Basic <based64 username:password>";
		proxy_set_header  X-Found-Cluster <cluster id>;
        proxy_pass  <cloud url>; # actual kibana URL

and when I try to call https://localhost:4443/goto/55077420-81bc-11ed-9098-f1b7c3308432

I'm getting {"error":"Incorrect HTTP method for uri [/goto/55077420-81bc-11ed-9098-f1b7c3308484] and method [GET], allowed: [POST]","status":405}.

I set in Kibana in the edit user settings:
xpack.security.sameSiteCookies: "None"

12 months ago it was working in the POC but I changed the cluster so I guess I'm missing something.


solved by removing the proxy_set_header X-Found-Cluster and
replace proxy_set_header Host $host; with proxy_set_header Host $proxy_host;

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.