Embedded Elasticsearch single node OutOfMemoryError

Hello Elasticsearch gurus,
I have Elasticsearch running as a single embedded node inside my web
application.
I noticed that as soon the index folder size on the disk exceed the size of
of the heap size (4GB in my case) the application become unresponsive and
soon I got an OutOfMemory error.
The elasticsearch.yml has default settings, nothing is change there.
Do you have any suggestions how can I configure elasticsearch to get rid of
this problem, except the obvious solution to increase the heap size value?
Thank you very much

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/dbe12dff-7f4f-4401-91e5-d6f4b5c655d2%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

I am using java6 and elasticsearch 1.1.2 version.
I am using only 1 shard, and 0 replica.
Any ideas?

On Monday, November 3, 2014 10:16:53 AM UTC+1, Doru Sular wrote:

Hello Elasticsearch gurus,
I have Elasticsearch running as a single embedded node inside my web
application.
I noticed that as soon the index folder size on the disk exceed the size
of of the heap size (4GB in my case) the application become unresponsive
and soon I got an OutOfMemory error.
The elasticsearch.yml has default settings, nothing is change there.
Do you have any suggestions how can I configure elasticsearch to get rid
of this problem, except the obvious solution to increase the heap size
value?
Thank you very much

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/2b6c5df0-a3fc-4bf0-8b47-40d89961b6ba%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Don't use java 6, you should be using 7 at a minimum, see
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/setup.html#jvm-version

On 4 November 2014 02:00, Doru Sular doru.sular@gmail.com wrote:

I am using java6 and elasticsearch 1.1.2 version.
I am using only 1 shard, and 0 replica.
Any ideas?

On Monday, November 3, 2014 10:16:53 AM UTC+1, Doru Sular wrote:

Hello Elasticsearch gurus,
I have Elasticsearch running as a single embedded node inside my web
application.
I noticed that as soon the index folder size on the disk exceed the size
of of the heap size (4GB in my case) the application become unresponsive
and soon I got an OutOfMemory error.
The elasticsearch.yml has default settings, nothing is change there.
Do you have any suggestions how can I configure elasticsearch to get rid
of this problem, except the obvious solution to increase the heap size
value?
Thank you very much

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/2b6c5df0-a3fc-4bf0-8b47-40d89961b6ba%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/2b6c5df0-a3fc-4bf0-8b47-40d89961b6ba%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAF3ZnZ%3DQ0w0rTftz9Fv8667R5rWhxtoPS1ukYfUPXgknjii9Bw%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.

Hi Mark, java 7 is a no go for me, because of my clients. However, I tryed
using java7 and the problem still persist.

On Monday, November 3, 2014 9:43:56 PM UTC+1, Mark Walkom wrote:

Don't use java 6, you should be using 7 at a minimum, see
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/setup.html#jvm-version

On 4 November 2014 02:00, Doru Sular <doru....@gmail.com <javascript:>>
wrote:

I am using java6 and elasticsearch 1.1.2 version.
I am using only 1 shard, and 0 replica.
Any ideas?

On Monday, November 3, 2014 10:16:53 AM UTC+1, Doru Sular wrote:

Hello Elasticsearch gurus,
I have Elasticsearch running as a single embedded node inside my web
application.
I noticed that as soon the index folder size on the disk exceed the size
of of the heap size (4GB in my case) the application become unresponsive
and soon I got an OutOfMemory error.
The elasticsearch.yml has default settings, nothing is change there.
Do you have any suggestions how can I configure elasticsearch to get rid
of this problem, except the obvious solution to increase the heap size
value?
Thank you very much

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/2b6c5df0-a3fc-4bf0-8b47-40d89961b6ba%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/2b6c5df0-a3fc-4bf0-8b47-40d89961b6ba%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/d73cf89d-2286-4157-a70a-f087c09c1a83%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.