Embedding kibana visualisation

Then I try to embed visualization into my Kibana app I receive an error.

webpack://%5Bname%5D/./node_modules/angular/angular.js?:14928 SearchError: Couldn't find a search strategy for the search request
at _callee$ (http://localhost:5601/wri/bundles/commons.bundle.js:133683:29)
at tryCatch (webpack://%5Bname%5D/./node_modules/regenerator-runtime/runtime.js?:62:40)
at Generator.invoke [as _invoke] (webpack://%5Bname%5D/./node_modules/regenerator-runtime/runtime.js?:288:22)
at Generator.prototype.<computed> [as next] (webpack://%5Bname%5D/./node_modules/regenerator-runtime/runtime.js?:114:21)
at asyncGeneratorStep (http://localhost:5601/wri/bundles/commons.bundle.js:133668:103)
at _next (http://localhost:5601/wri/bundles/commons.bundle.js:133670:194)
at http://localhost:5601/wri/bundles/commons.bundle.js:133670:364
at new Promise (<anonymous>)
at Object.<anonymous> (http://localhost:5601/wri/bundles/commons.bundle.js:133670:97)
at Object.search (http://localhost:5601/wri/bundles/commons.bundle.js:133710:22) "Possibly unhandled rejection: {"name":"SearchError","status":"418","title":"No search strategy registered","path":"","type":"NO_OP_SEARCH_STRATEGY"}"

I used this plugin to reproduce and got the same result

I test it with Kibana and Elasticsearch version 6.8.2 and got the same result then update them to 7.3.1

The same visualization on the Dashboard displayed correctly.

How could I debug, test and fix this issue?

@ppisljar can you plz guide here? using the kibana_sample_plugin here.

Thanks
Rashmi

that repository is out of date, rather take a look here:


I tried to launch this plugin.
Then I launch

node scripts/functional_tests_server.js --config test/plugin_functional/config.js

I see new application but can not switch visualization getting an error

VM5064 commons.bundle.js:143132 Uncaught (in promise) SavedObjectNotFound {message: "Could not locate that visualization (id: timebased_with-filters)", savedObjectType: "visualization", savedObjectId: "timebased_with-filters", stack: "Error: Could not locate that visualization (id: ti…ame%5D/./node_modules/angular/angular.js?:6719:7)"}

Could you please help? How to launch it right.

I fond a problem.
I do not include search library into my application
Then I added
import 'uiExports/search';
It starts including my vis