Enabling X-Pack Security


I just installed Elasticsearch on my ubuntu VM and I'm trying to run it for the first time but encountering errors.

I'm doing everything according to this tutorial: digitalocean

I added these lines:

discovery.type: single-node
xpack.security.enabled: true

to the end of the elasticsearch.yml file, but it still says:

Unexpected response code [500] from calling GET
It doesn't look like the X-Pack security feature is enabled on this Elasticsearch node.
Please check if you have enabled X-Pack security in your elasticsearch.yml configuration file.
ERROR: X-Pack Security is disabled by configuration.

any ideas why?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.