ERROR: X-Pack Security is disabled by configuration

Hello,

I have installed Elastic Search version number 6.5.4.
It says xpack is available by default in this version.

I have upgraded from Basic Licence to Trial Licence but I am not able to get xpack running.

It gives this error when I run elasticsearch-setup-passwords.bat interactive

Unexpected response code [404] from calling GET http://127.0.0.1:9200/_xpack/security/_authenticate?pretty
It doesn't look like the X-Pack security feature is enabled on this Elasticsearch node.
Please check if you have enabled X-Pack security in your elasticsearch.yml configuration file.

ERROR: X-Pack Security is disabled by configuration.

I have enabled xpack security in elasticsearch.yml.

Any help would be appreciated.

Thanx.

Installation of Elastic Search says no plugins loaded.
When I try to install xpack it says:
ERROR: this distribution of Elasticsearch contains X-Pack by default

Did you restart your node(s) after you modified the elasticsearch.yml file?

A common mistake people make is to leave the setting commented out, by putting a # at the beginning of the line that says xpack.security.enabled: true. There should be no #.

If it's not one of these things, can you please post your elasticsearch.yml file?

Hi,
Yes, I did restart the nodes couple of times.

# ======================== Elasticsearch Configuration =========================
#
# NOTE: Elasticsearch comes with reasonable defaults for most settings.
#       Before you set out to tweak and tune the configuration, make sure you
#       understand what are you trying to accomplish and the consequences.
#
# The primary way of configuring a node is via this file. This template lists
# the most important settings you may want to configure for a production cluster.
#
# Please consult the documentation for further information on configuration options:
# https://www.elastic.co/guide/en/elasticsearch/reference/index.html
#
# ---------------------------------- Cluster -----------------------------------
#
# Use a descriptive name for your cluster:
#
cluster.name: elasticsearch
cluster.routing.allocation.disk.threshold_enabled: true 
cluster.routing.allocation.disk.watermark.flood_stage: 5gb
cluster.routing.allocation.disk.watermark.low: 20gb 
cluster.routing.allocation.disk.watermark.high: 15gb
xpack.security.enabled: true
#
# ------------------------------------ Node ------------------------------------
#
# Use a descriptive name for the node:
#
node.name: HBOOTWALA
#
# Add custom attributes to the node:
#
#node.attr.rack: r1
#
# ----------------------------------- Paths ------------------------------------
#
# Path to directory where to store the data (separate multiple locations by comma):
#
path.data: C:\ElasticSearch\Data
#
# Path to log files:
#
path.logs: C:\ElasticSearch\Logs
#
# ----------------------------------- Memory -----------------------------------
#
# Lock the memory on startup:
#
#bootstrap.memory_lock: true
#
# Make sure that the heap size is set to about half the memory available
# on the system and that the owner of the process is allowed to use this
# limit.
#
# Elasticsearch performs poorly when the system is swapping the memory.
#
# ---------------------------------- Network -----------------------------------
#
# Set the bind address to a specific IP (IPv4 or IPv6):
#
#network.host: localhost:9200
#
# Set a custom port for HTTP:
#
#http.port: 9200
#
# For more information, consult the network module documentation.
#
# --------------------------------- Discovery ----------------------------------
#
# Pass an initial list of hosts to perform discovery when new node is started:
# The default list of hosts is ["127.0.0.1", "[::1]"]
#
#discovery.zen.ping.unicast.hosts: ["host1", "host2"]
#
# Prevent the "split brain" by configuring the majority of nodes (total number of master-eligible nodes / 2 + 1):
#
#discovery.zen.minimum_master_nodes: 2
#
# For more information, consult the zen discovery module documentation.
#
# ---------------------------------- Gateway -----------------------------------
#
# Block initial recovery after a full cluster restart until N nodes are started:
#
#gateway.recover_after_nodes: 3
#
# For more information, consult the gateway module documentation.
#
# ---------------------------------- Various -----------------------------------
#
# Require explicit names when deleting indices:
#
#action.destructive_requires_name: true

I have pasted elasticsearch.yml file.
Not sure if I have inserted xpack security line of code in the correct place.
Thanx.

That looks good to me. Can you also post the Elasticsearch logs, from since your restarted?

Hi,
Its very strange. Logs directory is empty.
There are other types of logs (gc.log and elasticsearch service logs) which does not help.
I have set a custom path for logs in elasticsearch.yml but there are no logs present.
Changed couple of things but no success.
Thanx.

It seems to me that your cluster is not using the elasticsearch.yml file that you have been editing. Did you install Elasticsearch using the Windows MSI installer? If so, check out the %ALLUSERSPROFILE%\Elastic\Elasticsearch\config directory. That is the default location that Elasticsearch will look for the elasticsearch.yml file.

You could also check the value of the ES_PATH_CONF environment variable. If set, this will determine the directory that Elasticsearch will use to look for the elasticsearch.yml file.

Hi,
Worked perfectly fine.
I had elastic installed through .msi.
Uninstalled it and then configured xpack which worked.
Appreciate your help.
Thank You.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.