Xpack Error in Elastic search. xpack settings not recognized

I am using Elasticsearch 7.1.0,
and im setting up my xpack such as:
xpack.security.enabled: true discovery.type: single-node
in my elasticsearch.yml.
Then, i ran
>elasticsearch-setup-passwords interactive

ERROR: Elasticsearch keystore file is missing [D:\ELK 7.1.0\elasticsearch\elasti

Then i tried creating the same by
>elasticsearch-keystore create

Created elasticsearch keystore in D:\ELK 7.1.0\elasticsearch\elasticsearch-7.1.0

Then im trying the interactive command again for which im getting,
>elasticsearch-setup-passwords interactive

Unexpected response code [500] from calling GET
It doesn't look like the X-Pack security feature is enabled on this Elasticsearc
h node.
Please check if you have enabled X-Pack security in your elasticsearch.yml confi
guration file.

ERROR: X-Pack Security is disabled by configuration.`

My xpack is enabled in my yml file.
What am i missing? Please help me.

From version 7.2 (?) some security features are available with the free basic license. Prior to that a commercial license was required. I would recommend you upgrade.

when i reinstalled 7.1.0 it worked fine.
leaving no spaces or blank lines after xpack settings in my yml file.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.