Encountered problem while starting elasticsearch on AWS


(Jongmin Kim) #1

Hi, I'm from Korea, country of kimchi :slight_smile:

I'm trying to run elasticsearch on AWS EC2 system.
I was following instruction
on http://www.elasticsearch.org/tutorials/elasticsearch-on-ec2/ page.

I installed aws plugin and configure config/elasticsearch.yml as follow.

cluster.name: candi
cloud:
aws:
region: ap-northeast-1
access_key: ****
secret_key: ****
discovery:
type: ec2
groups: candoop1
gateway:
type: s3
s3:
bucket: candoitsoft-elasticsearch-data

and when I run elasticsearch it shows me next.

[2014-01-22 12:22:48,387][INFO ][node ] [candoop1]
version[0.90.10], pid[1664], build[0a5781f/2014-01-10T10:18:37Z]
[2014-01-22 12:22:48,388][INFO ][node ] [candoop1]
initializing ...
[2014-01-22 12:22:48,557][INFO ][plugins ] [candoop1]
loaded [cloud-aws], sites []
[2014-01-22 12:22:48,567][ERROR][bootstrap ] {0.90.10}:
Initialization Failed ...

  • NoClassDefFoundError[org/elasticsearch/repositories/RepositoriesModule]
    ClassNotFoundException[org.elasticsearch.repositories.RepositoriesModule]

I found that there is a repositories.RepositoriesModule file on github
source
https://github.com/elasticsearch/elasticsearch/tree/master/src/main/java/org/elasticsearch/repositories

but when I download install file from elasticsearch.org download page
http://www.elasticsearch.org/download/
and unzipped elasticsearch-0.90.10.jar file under $ES_HOME/lib
there are no class files and package path org.elasticsearch.repositories

How can I recover this problem? Can I install elasticsearch directly from
github?
I'm not very familiar with github. so...

Thank you. Waiting answers.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/bfb1fc24-4f02-47ed-9514-dbd004d36f45%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(David Pilato) #2

You are trying to use AWS plugin 2.0.0.RC1 with elasticsearch 0.90.x.
This version only works with elasticsearch 1.0.0.RC1 and >

For 0.90.x, latest version is 1.16.0

See README:

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 22 janvier 2014 at 13:39:17, Jong Min Kim (kimjmin@gmail.com) a รฉcrit:

Hi, I'm from Korea, country of kimchi :slight_smile:

I'm trying to run elasticsearch on AWS EC2 system.
I was following instruction on http://www.elasticsearch.org/tutorials/elasticsearch-on-ec2/ page.

I installed aws plugin and configure config/elasticsearch.yml as follow.

cluster.name: candi
cloud:
aws:
region: ap-northeast-1
access_key: ****
secret_key: ****
discovery:
type: ec2
groups: candoop1
gateway:
type: s3
s3:
bucket: candoitsoft-elasticsearch-data

and when I run elasticsearch it shows me next.

[2014-01-22 12:22:48,387][INFO ][node ] [candoop1] version[0.90.10], pid[1664], build[0a5781f/2014-01-10T10:18:37Z]
[2014-01-22 12:22:48,388][INFO ][node ] [candoop1] initializing ...
[2014-01-22 12:22:48,557][INFO ][plugins ] [candoop1] loaded [cloud-aws], sites []
[2014-01-22 12:22:48,567][ERROR][bootstrap ] {0.90.10}: Initialization Failed ...

  • NoClassDefFoundError[org/elasticsearch/repositories/RepositoriesModule]
    ClassNotFoundException[org.elasticsearch.repositories.RepositoriesModule]

I found that there is a repositories.RepositoriesModule file on github source
https://github.com/elasticsearch/elasticsearch/tree/master/src/main/java/org/elasticsearch/repositories

but when I download install file from elasticsearch.org download page
http://www.elasticsearch.org/download/
and unzipped elasticsearch-0.90.10.jar file under $ES_HOME/lib
there are no class files and package path org.elasticsearch.repositories

How can I recover this problem? Can I install elasticsearch directly from github?
I'm not very familiar with github. so...

Thank you. Waiting answers.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/bfb1fc24-4f02-47ed-9514-dbd004d36f45%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/etPan.52dff66f.4e6afb66.74cd%40MacBook-Air-de-David.local.
For more options, visit https://groups.google.com/groups/opt_out.


(Jongmin Kim) #3

Thanks! Really appreciate for your answer. :slight_smile:

2014๋…„ 1์›” 23์ผ ๋ชฉ์š”์ผ ์˜ค์ „ 1์‹œ 48๋ถ„ 41์ดˆ UTC+9, David Pilato ๋‹˜์˜ ๋ง:

You are trying to use AWS plugin 2.0.0.RC1 with elasticsearch 0.90.x.
This version only works with elasticsearch 1.0.0.RC1 and >

For 0.90.x, latest version is 1.16.0

See README:

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 22 janvier 2014 at 13:39:17, Jong Min Kim (kim...@gmail.com<javascript:>)
a รฉcrit:

Hi, I'm from Korea, country of kimchi :slight_smile:

I'm trying to run elasticsearch on AWS EC2 system.
I was following instruction on
http://www.elasticsearch.org/tutorials/elasticsearch-on-ec2/ page.

I installed aws plugin and configure config/elasticsearch.yml as follow.

cluster.name: candi
cloud:
aws:
region: ap-northeast-1
access_key: ****
secret_key: ****
discovery:
type: ec2
groups: candoop1
gateway:
type: s3
s3:
bucket: candoitsoft-elasticsearch-data

and when I run elasticsearch it shows me next.

[2014-01-22 12:22:48,387][INFO ][node ] [candoop1]
version[0.90.10], pid[1664], build[0a5781f/2014-01-10T10:18:37Z]
[2014-01-22 12:22:48,388][INFO ][node ] [candoop1]
initializing ...
[2014-01-22 12:22:48,557][INFO ][plugins ] [candoop1]
loaded [cloud-aws], sites []
[2014-01-22 12:22:48,567][ERROR][bootstrap ] {0.90.10}:
Initialization Failed ...

  • NoClassDefFoundError[org/elasticsearch/repositories/RepositoriesModule]
    ClassNotFoundException[org.elasticsearch.repositories.RepositoriesModule]

I found that there is a repositories.RepositoriesModule file on github
source

https://github.com/elasticsearch/elasticsearch/tree/master/src/main/java/org/elasticsearch/repositories

but when I download install file from elasticsearch.org download page
http://www.elasticsearch.org/download/
and unzipped elasticsearch-0.90.10.jar file under $ES_HOME/lib
there are no class files and package path org.elasticsearch.repositories

How can I recover this problem? Can I install elasticsearch directly from
github?
I'm not very familiar with github. so...

Thank you. Waiting answers.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/bfb1fc24-4f02-47ed-9514-dbd004d36f45%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/43a99dc1-a710-4a0d-8092-da4850efb11e%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #4