Mismatch versions ES AWS Plugin?


(Ryan Tabora) #1

Hey all,

I am guessing I am running into a versioning problem but I am unsure. I am
using elasticsearch-1.2.0 and elasticsearch-aws plugin 2.1.1.

The error I get after installing the plugin and running elasticsearch is:

{1.2.0}: Initialization Failed ...

NoClassDefFoundError[org/elasticsearch/gateway/blobstore/BlobStoreGatewayModule]
ClassNotFoundException[org.elasticsearch.gateway.blobstore.BlobStoreGatewayModule]

I am looking at the elasticsearch-aws github page
https://github.com/elasticsearch/elasticsearch-cloud-aws/tree/es-1.2 and
see that I should be using 2.2.0-SNAPSHOT? Does that mean I have to
manually build the plugin if I want to use the stable ES build?

The latest release of elasticsearch-aws is 2.1.1
https://github.com/elasticsearch/elasticsearch-cloud-aws/releases.

Thanks for help in advance!

Ryan

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/a985519c-d4c4-4807-824c-ea6afd1c1bd3%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(David Pilato) #2

Indeed. We need to release it.
In the mean time, you can build it by yourself and install it manually.

Best

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 3 juin 2014 à 00:57, Ryan Tabora ratabora@gmail.com a écrit :

Hey all,

I am guessing I am running into a versioning problem but I am unsure. I am using elasticsearch-1.2.0 and elasticsearch-aws plugin 2.1.1.

The error I get after installing the plugin and running elasticsearch is:

{1.2.0}: Initialization Failed ...

  • NoClassDefFoundError[org/elasticsearch/gateway/blobstore/BlobStoreGatewayModule]
    ClassNotFoundException[org.elasticsearch.gateway.blobstore.BlobStoreGatewayModule]

I am looking at the elasticsearch-aws github page and see that I should be using 2.2.0-SNAPSHOT? Does that mean I have to manually build the plugin if I want to use the stable ES build?

The latest release of elasticsearch-aws is 2.1.1.

Thanks for help in advance!

Ryan

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/a985519c-d4c4-4807-824c-ea6afd1c1bd3%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/1D8D5CA9-9376-4480-B34E-962FEA2CD41D%40pilato.fr.
For more options, visit https://groups.google.com/d/optout.


(Richard Baker) #3

Having the same issue here. Installed 2.1.1 on CentOS via RPM following
this guide:

http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/setup-repositories.html

Then this:

http://www.elasticsearch.org/tutorials/elasticsearch-on-ec2/

Using: bin/plugin -install elasticsearch/elasticsearch-cloud-aws/2.1.1

Resulting in:

[2014-06-11 10:07:05,542][ERROR][bootstrap ] {1.2.1}:
Initialization Failed ...

NoClassDefFoundError[org/elasticsearch/gateway/blobstore/BlobStoreGatewayModule]
ClassNotFoundException[org.elasticsearch.gateway.blobstore.BlobStoreGatewayModule]

The documentation is very confusing, and there are no details on how to
manually build the AWS plugin to resolve this issue or indeed which version
I should be building. Please could anyone advise?

Many thanks.

On Tuesday, 3 June 2014 06:43:46 UTC+1, David Pilato wrote:

Indeed. We need to release it.
In the mean time, you can build it by yourself and install it manually.

Best

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 3 juin 2014 à 00:57, Ryan Tabora <rata...@gmail.com <javascript:>> a
écrit :

Hey all,

I am guessing I am running into a versioning problem but I am unsure. I am
using elasticsearch-1.2.0 and elasticsearch-aws plugin 2.1.1.

The error I get after installing the plugin and running elasticsearch is:

{1.2.0}: Initialization Failed ...

NoClassDefFoundError[org/elasticsearch/gateway/blobstore/BlobStoreGatewayModule]

ClassNotFoundException[org.elasticsearch.gateway.blobstore.BlobStoreGatewayModule]

I am looking at the elasticsearch-aws github page
https://github.com/elasticsearch/elasticsearch-cloud-aws/tree/es-1.2
and see that I should be using 2.2.0-SNAPSHOT? Does that mean I have to
manually build the plugin if I want to use the stable ES build?

The latest release of elasticsearch-aws is 2.1.1
https://github.com/elasticsearch/elasticsearch-cloud-aws/releases.

Thanks for help in advance!

Ryan

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/a985519c-d4c4-4807-824c-ea6afd1c1bd3%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/a985519c-d4c4-4807-824c-ea6afd1c1bd3%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/e7a9a9e9-0cef-4166-a634-6b6ad56132d2%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #4