ES fails to load plugin - what am I missing?


(Frank Flynn) #1

Hi everyone,

I'm trying to do a back up to S3. I'm running ES "version" : "1.1.1",
"build" : "f1585f0" and I have tried to install the plugin on all the nodes

bin/plugin -install elasticsearch/elasticsearch-cloud-aws/2.1.1

which appeared to work (no errors) and I restarted all of the nodes. but
it did not work - when I try to create a snapshot using "type": "s3" I get
an error:

NoClassSettingsException[failed to load class with value [s3];

And when I do the _nodes query it shows (among many other things):

"plugins" : [ ]

So I tried to install the elasticsearch-cloud-aws/2.1.1 plugin again and I
get an error saying that directory exists and I should uninstall if I want
to update. So what did I miss? Why is this lot loading - there is nothing
in the error logs at all.

Thanks for any help,
Frank

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/c00a2ae4-01ae-4326-8aac-49b551cf4c01%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Frank Flynn) #2

OK - never mind ---

/etc/init.d/elasticsearch restart didn't really restart it. Got it really
restarted and the plugin shows up.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/c5a7119d-cc83-489e-83ae-b73df3ea8ccc%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Alexander Reelsen) #3

Hey,

glad you solved it. Just for future reference: you can use the nodes info
API to see your installed plugins like this:
http://localhost:9200/_nodes/plugins

If you have further problems with restarted using the init script, which is
packaged with ES, dont hesitate to create an issue!

--Alex

On Sat, Jun 28, 2014 at 12:20 AM, Frank Flynn faultlessfrank@gmail.com
wrote:

OK - never mind ---

/etc/init.d/elasticsearch restart didn't really restart it. Got it
really restarted and the plugin shows up.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/c5a7119d-cc83-489e-83ae-b73df3ea8ccc%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/c5a7119d-cc83-489e-83ae-b73df3ea8ccc%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAGCwEM_W5%3D6oE%3DkF289MohtFFxycwRBGwWVN%2B_YRfWU2O%3DyBOw%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(system) #4