Ensure a healthy Elasticsearch cluster is running at https://172.19.0.2:9200 for user elastic

Ensure a healthy Elasticsearch cluster is running at https://172.19.0.2:9200 for user elastic.

When I run docker of enterprise-search,
it fails to run with this message when I entered on Kibana
http://kibana-url:5601/app/enterprise_search/overview

it is working with Elasticsearch and enterprise-search together? or not?

[2022-03-08T16:47:50.434+00:00][8][2000][app-server][ERROR]: Could not connect to Elasticsearch backend after 600 seconds. Terminating...
[2022-03-08T16:47:50.437+00:00][8][2000][app-server][ERROR]:

Enterprise Search is unable to connect to Elasticsearch. Ensure a healthy Elasticsearch cluster is running at https://172.19.0.2:9200 for user elastic.


Hey @suminlim,

It seems that Enterprise Search isn't able to access Elasticsearch using the host/username/password specified. You could try to SSH into the Enterprise Search docker container and attempt to issue a basic request to Elasticsearch in order to test/verify the connection. Something like:

curl -u [USERNAME]:[PASSWORD] https://[HOST AND PORT]/_cat/health

Let me know if that helps!

Ross

I solved this issue.

sudo docker run --name enterprise-search --net elastic -p 3002:3002 --volume es-config:/usr/share/enterprise-search/es-config:ro
--env "secret_management.encryption_keys=['40fd6404b8ab12431f9f4216d3932e064b915a8959c3a417bbd39e87ac2b0bf3']" \ <--- when ES run initially it returns this key
--env "allow_es_settings_modification=true"
--env "Elasticsearch.host=https://elastic:changeme@172.19.0.2:9200"
--env "Elasticsearch.username=elastic" --env "Elasticsearch.password=changeme"
--env "Elasticsearch.ssl.enabled=true" --env "allow_es_settings_modification=true"
--env "Elasticsearch.ssl.certificate_authority=/usr/share/enterprise-search/es-config/certs/http_ca.crt"
--env "kibana.external_url=http://172.19.0.3:5601"
"docker.elastic.co/enterprise-search/enterprise-search:8.0.1"

172.19.0.3~ these kind of ip address is Interal docker ip address.
OFFICIAL GUIDE SHOULD BE updated like below: Elasticsearch.host=https://elastic:changeme@172.19.0.2:9200
it does not described elastic:changeme this.