Error connecting to sql database

I need help to connect to the sql server database.
I downloaded a connector and already put n specific folder, but it's giving an error with the following.
Note; I can already connect to mysql database but sql server will be the first time, can you please help me?

[ERROR] 2021-06-28 07:55:31.242 [[main]<jdbc] jdbc - Unable to connect to database. Tried 1 times {:error_message=>"Java::JavaLang::NoClassDefFoundError: javax/xml/bind/DatatypeConverter"}
[ERROR] 2021-06-28 07:55:31.244 [[main]<jdbc] javapipeline - A plugin had an unrecoverable error. Will restart this plugin.

#jdbc_driver_library => "/home/elasticstack/logstash/mysql-connector-java-8.0.16/mysql-connector-java-8.0.16.jar"
jdbc_driver_class => ""
jdbc_connection_string => "jdbc:sqlserver://X.X.X.X:1433;databaseName=XXXXX;integratedSecurity=false"
#jdbc_driver_library => "/usr/share/logstash/logstash-core/lib/jars/sqljdbc42.jar"
jdbc_user => "xxxx"
jdbc_password => "xxxx"
type => "lanlinktactium"
# dbc
statement => "

Another thing, when it comes to a mysql database I just need the IP and the port, for the sql server I received a different type like that: bancosql\bc01

Damm even I am having a similar kind of issue, I have searched all over the internet and even have posted on number of threads on different forum, no solution seems to work. I am really frustrated, can anyone of you here help me resolve this issue, I am very much tired now.

Friend, I changed my connector, and apparently it worked, let's see if someone more experienced can help us, but follow where I can, maybe it will help.

yes, i think it can be helpful . .

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.