Error if FunctionBeat´s lambda name is changed

I'm trying to deploy Functionbeat lambda in AWS with a custom name. If I deploy it with the default name, cloudwatch, it works successfully but if I change the default name to any other name, once deployed it doesn't work, it fails with the following error:

fork/exec /var/task/functionbeat-aws: no such file or directory: PathError null

This is a snippet of the configuration file (the value of the name field is the one that i'm trying to change):

  # Define the list of function availables, each function required to have a unique name.
  # Create a function that accepts events coming from cloudwatchlogs.
  - name: cloudwatch
    enabled: true
    type: cloudwatch_logs

¿How can I change the name of the lambda function? Suggestions are well appreciated : )


Is this a similar problem: go - Getting error "fork/exec /var/task/main: no such file or directory" while executing aws-lambda function - Stack Overflow ?

Maybe, but I don't have the source code of the FunctionBeat so I can't check it. I tried changing the handler name as suggested in that URL but I get the same error.

The curious thing about this is that if I set the function name as "cloudwatch" it works, if i change the name of the function to "testfunction" or whatever keeping the rest of the configuration untouched, it stops working.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.