ERROR in bootstrap. ES 0.7.1


(tfreitas) #1

Hi

When I test ES 0.7.1 with zero configuration (elasticsearch.yml
empty)

This error occurs

[17:26:45,627] [ERROR] [bootstrap] [Duquesne, Jacques] ()
ElasticSearch/0.7.1: Startup Failed ...

  • DiscoveryException [Failed to setup multicast socket]
    SocketException [bad argument for IP_MULTICAST_IF: Not bound to Any
    address interface]

I use Ubuntu 9.10

In previous versions always work with zero configuration


(Shay Banon) #2

Hi,

First, can you set bootstrap to DEBUG level, and attache the log?
Basically, open the logging.yml file and replace the header with this:

rootLogger: INFO, console, file
logger:

log action execution errors for easier debugging

action : DEBUG
bootstrap: DEBUG

Second, there is a new discovery module called zen, and by default, it
uses multicast discovery. The exception would help me understand where this
is coming from...

Thanks,
shay.banon

On Thu, May 20, 2010 at 1:03 AM, tfreitas tfreitas@gmail.com wrote:

Hi

When I test ES 0.7.1 with zero configuration (elasticsearch.yml
empty)

This error occurs

[17:26:45,627] [ERROR] [bootstrap] [Duquesne, Jacques] ()
ElasticSearch/0.7.1: Startup Failed ...

  • DiscoveryException [Failed to setup multicast socket]
    SocketException [bad argument for IP_MULTICAST_IF: Not bound to Any
    address interface]

I use Ubuntu 9.10

In previous versions always work with zero configuration


(tfreitas) #3

This is the log:


[18:23:13,577][INFO ][node ] [Nitro]
{ElasticSearch/0.7.1}[7138]: Initializing ...
[18:23:13,597][INFO ][plugins ] [Nitro] Loaded []
[18:23:15,243][DEBUG][threadpool.cached ] [Nitro] Initializing
cached thread pool with keep_alive[1m], scheduled_size[20]
[18:23:15,390][DEBUG][discovery.zen.ping.multicast] [Nitro] Using
group [224.2.2.4], with port [54328], ttl [3], and address [null]
[18:23:15,396][DEBUG][discovery.zen ] [Nitro] Using
initial_ping_timeout [3s]
[18:23:15,399][DEBUG][discovery.zen.fd ] [Nitro] Master FD
uses ping_interval [1s], ping_timeout [30s], ping_retries [3]
[18:23:15,415][DEBUG][discovery.zen.fd ] [Nitro] Nodes FD uses
ping_interval [1s], ping_timeout [30s], ping_retries [3]
[18:23:15,556][DEBUG][monitor.memory.alpha ] [Nitro]
interval[500ms], upper_memory_threshold[0.8],
lower_memory_threshold[0.5],
translog_number_of_operations_threshold[5000]
[18:23:15,893][DEBUG][indices.recovery.throttler] [Nitro]
concurrent_recoveries [1], concurrent_streams [1] interval [100ms]
[18:23:15,895][INFO ][node ] [Nitro]
{ElasticSearch/0.7.1}[7138]: Initialized
[18:23:15,895][INFO ][node ] [Nitro]
{ElasticSearch/0.7.1}[7138]: Starting ...
[18:23:15,995][DEBUG][netty.channel.socket.nio.NioProviderMetadata]
Using the autodetected NIO constraint level: 0
[18:23:16,185][DEBUG][transport.netty ] [Nitro] Bound to
address [/0:0:0:0:0:0:0:0:9300]
[18:23:16,187][INFO ][transport ] [Nitro]
bound_address[inet[/0:0:0:0:0:0:0:0:9300]], publish_address[inet[Tony/
127.0.1.1:9300]]
[18:23:16,268][ERROR][bootstrap ] [Nitro]
{ElasticSearch/0.7.1}: e[31mStartup Failed ...e[0m

  • DiscoveryException[Failed to setup multicast socket]
    SocketException[bad argument for IP_MULTICAST_IF: address not bound
    to any interface]
    [18:23:16,270][DEBUG][bootstrap ] [Nitro] Exception
    org.elasticsearch.discovery.DiscoveryException: Failed to setup
    multicast socket
    at
    org.elasticsearch.discovery.zen.ping.multicast.MulticastZenPing.doStart(MulticastZenPing.java:
at

org.elasticsearch.util.component.AbstractLifecycleComponent.start(AbstractLifecycleComponent.java:
80)
at
org.elasticsearch.discovery.zen.ping.ZenPingService.doStart(ZenPingService.java:
93)
at
org.elasticsearch.util.component.AbstractLifecycleComponent.start(AbstractLifecycleComponent.java:
80)
at
org.elasticsearch.discovery.zen.ZenDiscovery.doStart(ZenDiscovery.java:
137)
at
org.elasticsearch.util.component.AbstractLifecycleComponent.start(AbstractLifecycleComponent.java:
80)
at
org.elasticsearch.discovery.DiscoveryService.doStart(DiscoveryService.java:
58)
at
org.elasticsearch.util.component.AbstractLifecycleComponent.start(AbstractLifecycleComponent.java:
80)
at
org.elasticsearch.node.internal.InternalNode.start(InternalNode.java:
173)
at org.elasticsearch.bootstrap.Bootstrap.start(Bootstrap.java:115)
at org.elasticsearch.bootstrap.Bootstrap.main(Bootstrap.java:168)
Caused by: java.net.SocketException: bad argument for IP_MULTICAST_IF:
address not bound to any interface
at java.net.PlainDatagramSocketImpl.socketSetOption(Native Method)
at
java.net.PlainDatagramSocketImpl.setOption(PlainDatagramSocketImpl.java:
299)
at java.net.MulticastSocket.setInterface(MulticastSocket.java:424)
at
org.elasticsearch.discovery.zen.ping.multicast.MulticastZenPing.doStart(MulticastZenPing.java:
143)
... 10 more
[18:23:16,296][INFO ][node ] [Nitro]
{ElasticSearch/0.7.1}[7138]: Stopping ...
[18:23:16,319][INFO ][node ] [Nitro]
{ElasticSearch/0.7.1}[7138]: Stopped
[18:23:16,319][INFO ][node ] [Nitro]
{ElasticSearch/0.7.1}[7138]: Closing ...
[18:23:16,323][DEBUG][threadpool.cached ] [Nitro] Shutting down
cached thread pool
[18:23:16,338][INFO ][node ] [Nitro]
{ElasticSearch/0.7.1}[7138]: Closed


On May 19, 6:08 pm, Shay Banon shay.ba...@elasticsearch.com wrote:

Hi,

First, can you set bootstrap to DEBUG level, and attache the log?
Basically, open the logging.yml file and replace the header with this:

rootLogger: INFO, console, file
logger:

log action execution errors for easier debugging

action : DEBUG
bootstrap: DEBUG

Second, there is a new discovery module called zen, and by default, it
uses multicast discovery. The exception would help me understand where this
is coming from...

Thanks,
shay.banon

On Thu, May 20, 2010 at 1:03 AM, tfreitas tfrei...@gmail.com wrote:

Hi

When I test ES 0.7.1 with zero configuration (elasticsearch.yml
empty)

This error occurs

[17:26:45,627] [ERROR] [bootstrap] [Duquesne, Jacques] ()
ElasticSearch/0.7.1: Startup Failed ...

  • DiscoveryException [Failed to setup multicast socket]
    SocketException [bad argument for IP_MULTICAST_IF: Not bound to Any
    address interface]

I use Ubuntu 9.10

In previous versions always work with zero configuration


(Shay Banon) #4

Hi,

This is strange, as you can see, the publish address of the transport is
127.0.0.1, which means if you start a node on another machine, they will not
talk to each other. Can you send your ifconfig?

cheers,
shay.banon

On Thu, May 20, 2010 at 1:54 AM, tfreitas tfreitas@gmail.com wrote:

This is the log:


[18:23:13,577][INFO ][node ] [Nitro]
{ElasticSearch/0.7.1}[7138]: Initializing ...
[18:23:13,597][INFO ][plugins ] [Nitro] Loaded []
[18:23:15,243][DEBUG][threadpool.cached ] [Nitro] Initializing
cached thread pool with keep_alive[1m], scheduled_size[20]
[18:23:15,390][DEBUG][discovery.zen.ping.multicast] [Nitro] Using
group [224.2.2.4], with port [54328], ttl [3], and address [null]
[18:23:15,396][DEBUG][discovery.zen ] [Nitro] Using
initial_ping_timeout [3s]
[18:23:15,399][DEBUG][discovery.zen.fd ] [Nitro] Master FD
uses ping_interval [1s], ping_timeout [30s], ping_retries [3]
[18:23:15,415][DEBUG][discovery.zen.fd ] [Nitro] Nodes FD uses
ping_interval [1s], ping_timeout [30s], ping_retries [3]
[18:23:15,556][DEBUG][monitor.memory.alpha ] [Nitro]
interval[500ms], upper_memory_threshold[0.8],
lower_memory_threshold[0.5],
translog_number_of_operations_threshold[5000]
[18:23:15,893][DEBUG][indices.recovery.throttler] [Nitro]
concurrent_recoveries [1], concurrent_streams [1] interval [100ms]
[18:23:15,895][INFO ][node ] [Nitro]
{ElasticSearch/0.7.1}[7138]: Initialized
[18:23:15,895][INFO ][node ] [Nitro]
{ElasticSearch/0.7.1}[7138]: Starting ...
[18:23:15,995][DEBUG][netty.channel.socket.nio.NioProviderMetadata]
Using the autodetected NIO constraint level: 0
[18:23:16,185][DEBUG][transport.netty ] [Nitro] Bound to
address [/0:0:0:0:0:0:0:0:9300]
[18:23:16,187][INFO ][transport ] [Nitro]
bound_address[inet[/0:0:0:0:0:0:0:0:9300]], publish_address[inet[Tony/
127.0.1.1:9300]]
[18:23:16,268][ERROR][bootstrap ] [Nitro]
{ElasticSearch/0.7.1}: [31mStartup Failed ... [0m

  • DiscoveryException[Failed to setup multicast socket]
    SocketException[bad argument for IP_MULTICAST_IF: address not bound
    to any interface]
    [18:23:16,270][DEBUG][bootstrap ] [Nitro] Exception
    org.elasticsearch.discovery.DiscoveryException: Failed to setup
    multicast socket
    at

org.elasticsearch.discovery.zen.ping.multicast.MulticastZenPing.doStart(MulticastZenPing.java:
151)
at

org.elasticsearch.util.component.AbstractLifecycleComponent.start(AbstractLifecycleComponent.java:
80)
at

org.elasticsearch.discovery.zen.ping.ZenPingService.doStart(ZenPingService.java:
93)
at

org.elasticsearch.util.component.AbstractLifecycleComponent.start(AbstractLifecycleComponent.java:
80)
at
org.elasticsearch.discovery.zen.ZenDiscovery.doStart(ZenDiscovery.java:
137)
at

org.elasticsearch.util.component.AbstractLifecycleComponent.start(AbstractLifecycleComponent.java:
80)
at
org.elasticsearch.discovery.DiscoveryService.doStart(DiscoveryService.java:
58)
at

org.elasticsearch.util.component.AbstractLifecycleComponent.start(AbstractLifecycleComponent.java:
80)
at
org.elasticsearch.node.internal.InternalNode.start(InternalNode.java:
173)
at org.elasticsearch.bootstrap.Bootstrap.start(Bootstrap.java:115)
at org.elasticsearch.bootstrap.Bootstrap.main(Bootstrap.java:168)
Caused by: java.net.SocketException: bad argument for IP_MULTICAST_IF:
address not bound to any interface
at java.net.PlainDatagramSocketImpl.socketSetOption(Native Method)
at
java.net.PlainDatagramSocketImpl.setOption(PlainDatagramSocketImpl.java:
299)
at java.net.MulticastSocket.setInterface(MulticastSocket.java:424)
at

org.elasticsearch.discovery.zen.ping.multicast.MulticastZenPing.doStart(MulticastZenPing.java:
143)
... 10 more
[18:23:16,296][INFO ][node ] [Nitro]
{ElasticSearch/0.7.1}[7138]: Stopping ...
[18:23:16,319][INFO ][node ] [Nitro]
{ElasticSearch/0.7.1}[7138]: Stopped
[18:23:16,319][INFO ][node ] [Nitro]
{ElasticSearch/0.7.1}[7138]: Closing ...
[18:23:16,323][DEBUG][threadpool.cached ] [Nitro] Shutting down
cached thread pool
[18:23:16,338][INFO ][node ] [Nitro]
{ElasticSearch/0.7.1}[7138]: Closed


On May 19, 6:08 pm, Shay Banon shay.ba...@elasticsearch.com wrote:

Hi,

First, can you set bootstrap to DEBUG level, and attache the log?
Basically, open the logging.yml file and replace the header with this:

rootLogger: INFO, console, file
logger:

log action execution errors for easier debugging

action : DEBUG
bootstrap: DEBUG

Second, there is a new discovery module called zen, and by default, it
uses multicast discovery. The exception would help me understand where
this
is coming from...

Thanks,
shay.banon

On Thu, May 20, 2010 at 1:03 AM, tfreitas tfrei...@gmail.com wrote:

Hi

When I test ES 0.7.1 with zero configuration (elasticsearch.yml
empty)

This error occurs

[17:26:45,627] [ERROR] [bootstrap] [Duquesne, Jacques] ()
ElasticSearch/0.7.1: Startup Failed ...

  • DiscoveryException [Failed to setup multicast socket]
    SocketException [bad argument for IP_MULTICAST_IF: Not bound to Any
    address interface]

I use Ubuntu 9.10

In previous versions always work with zero configuration


(tfreitas) #5

My ifconfig is:

eth0 Link encap:Ethernet HWaddr 00:0f:fe:02:ee:e5
inet addr:10.3.1.48 Bcast:10.3.255.255 Mask:255.255.0.0
inet6 addr: fe80::20f:feff:fe02:eee5/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:101862 errors:0 dropped:0 overruns:0 frame:0
TX packets:28375 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:43398354 (43.3 MB) TX bytes:5090313 (5.0 MB)
Interrupt:19

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:10 errors:0 dropped:0 overruns:0 frame:0
TX packets:10 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:688 (688.0 B) TX bytes:688 (688.0 B)

When I configure elasticsearch.yml with
network:
host: 10.3.1.48

Everything is OK

On May 20, 12:11 pm, Shay Banon shay.ba...@elasticsearch.com wrote:

Hi,

This is strange, as you can see, the publish address of the transport is
127.0.0.1, which means if you start a node on another machine, they will not
talk to each other. Can you send your ifconfig?

cheers,
shay.banon

On Thu, May 20, 2010 at 1:54 AM, tfreitas tfrei...@gmail.com wrote:

This is the log:


[18:23:13,577][INFO ][node ] [Nitro]
{ElasticSearch/0.7.1}[7138]: Initializing ...
[18:23:13,597][INFO ][plugins ] [Nitro] Loaded []
[18:23:15,243][DEBUG][threadpool.cached ] [Nitro] Initializing
cached thread pool with keep_alive[1m], scheduled_size[20]
[18:23:15,390][DEBUG][discovery.zen.ping.multicast] [Nitro] Using
group [224.2.2.4], with port [54328], ttl [3], and address [null]
[18:23:15,396][DEBUG][discovery.zen ] [Nitro] Using
initial_ping_timeout [3s]
[18:23:15,399][DEBUG][discovery.zen.fd ] [Nitro] Master FD
uses ping_interval [1s], ping_timeout [30s], ping_retries [3]
[18:23:15,415][DEBUG][discovery.zen.fd ] [Nitro] Nodes FD uses
ping_interval [1s], ping_timeout [30s], ping_retries [3]
[18:23:15,556][DEBUG][monitor.memory.alpha ] [Nitro]
interval[500ms], upper_memory_threshold[0.8],
lower_memory_threshold[0.5],
translog_number_of_operations_threshold[5000]
[18:23:15,893][DEBUG][indices.recovery.throttler] [Nitro]
concurrent_recoveries [1], concurrent_streams [1] interval [100ms]
[18:23:15,895][INFO ][node ] [Nitro]
{ElasticSearch/0.7.1}[7138]: Initialized
[18:23:15,895][INFO ][node ] [Nitro]
{ElasticSearch/0.7.1}[7138]: Starting ...
[18:23:15,995][DEBUG][netty.channel.socket.nio.NioProviderMetadata]
Using the autodetected NIO constraint level: 0
[18:23:16,185][DEBUG][transport.netty ] [Nitro] Bound to
address [/0:0:0:0:0:0:0:0:9300]
[18:23:16,187][INFO ][transport ] [Nitro]
bound_address[inet[/0:0:0:0:0:0:0:0:9300]], publish_address[inet[Tony/
127.0.1.1:9300]]
[18:23:16,268][ERROR][bootstrap ] [Nitro]
{ElasticSearch/0.7.1}: [31mStartup Failed ... [0m

  • DiscoveryException[Failed to setup multicast socket]
    SocketException[bad argument for IP_MULTICAST_IF: address not bound
    to any interface]
    [18:23:16,270][DEBUG][bootstrap ] [Nitro] Exception
    org.elasticsearch.discovery.DiscoveryException: Failed to setup
    multicast socket
    at

org.elasticsearch.discovery.zen.ping.multicast.MulticastZenPing.doStart(MulticastZenPing.java:
151)
at

org.elasticsearch.util.component.AbstractLifecycleComponent.start(AbstractLifecycleComponent.java:
80)
at

org.elasticsearch.discovery.zen.ping.ZenPingService.doStart(ZenPingService.java:
93)
at

org.elasticsearch.util.component.AbstractLifecycleComponent.start(AbstractLifecycleComponent.java:
80)
at
org.elasticsearch.discovery.zen.ZenDiscovery.doStart(ZenDiscovery.java:
137)
at

org.elasticsearch.util.component.AbstractLifecycleComponent.start(AbstractLifecycleComponent.java:
80)
at
org.elasticsearch.discovery.DiscoveryService.doStart(DiscoveryService.java:
58)
at

org.elasticsearch.util.component.AbstractLifecycleComponent.start(AbstractLifecycleComponent.java:
80)
at
org.elasticsearch.node.internal.InternalNode.start(InternalNode.java:
173)
at org.elasticsearch.bootstrap.Bootstrap.start(Bootstrap.java:115)
at org.elasticsearch.bootstrap.Bootstrap.main(Bootstrap.java:168)
Caused by: java.net.SocketException: bad argument for IP_MULTICAST_IF:
address not bound to any interface
at java.net.PlainDatagramSocketImpl.socketSetOption(Native Method)
at
java.net.PlainDatagramSocketImpl.setOption(PlainDatagramSocketImpl.java:
299)
at java.net.MulticastSocket.setInterface(MulticastSocket.java:424)
at

org.elasticsearch.discovery.zen.ping.multicast.MulticastZenPing.doStart(MulticastZenPing.java:
143)
... 10 more
[18:23:16,296][INFO ][node ] [Nitro]
{ElasticSearch/0.7.1}[7138]: Stopping ...
[18:23:16,319][INFO ][node ] [Nitro]
{ElasticSearch/0.7.1}[7138]: Stopped
[18:23:16,319][INFO ][node ] [Nitro]
{ElasticSearch/0.7.1}[7138]: Closing ...
[18:23:16,323][DEBUG][threadpool.cached ] [Nitro] Shutting down
cached thread pool
[18:23:16,338][INFO ][node ] [Nitro]
{ElasticSearch/0.7.1}[7138]: Closed


On May 19, 6:08 pm, Shay Banon shay.ba...@elasticsearch.com wrote:

Hi,

First, can you set bootstrap to DEBUG level, and attache the log?
Basically, open the logging.yml file and replace the header with this:

rootLogger: INFO, console, file
logger:

log action execution errors for easier debugging

action : DEBUG
bootstrap: DEBUG

Second, there is a new discovery module called zen, and by default, it
uses multicast discovery. The exception would help me understand where
this
is coming from...

Thanks,
shay.banon

On Thu, May 20, 2010 at 1:03 AM, tfreitas tfrei...@gmail.com wrote:

Hi

When I test ES 0.7.1 with zero configuration (elasticsearch.yml
empty)

This error occurs

[17:26:45,627] [ERROR] [bootstrap] [Duquesne, Jacques] ()
ElasticSearch/0.7.1: Startup Failed ...

  • DiscoveryException [Failed to setup multicast socket]
    SocketException [bad argument for IP_MULTICAST_IF: Not bound to Any
    address interface]

I use Ubuntu 9.10

In previous versions always work with zero configuration


(Shay Banon) #6

I think the problem is with the default address chosen for the "publish"
address (the external address of the node). Seems like when I call for the
local address in elasticsearch, in your case, it returns lo instead of eth0.

So, I have made the following changes (and by the way, usually this
indicates wrong network settings on the os level):

  1. The publish address, when not set, will now first try to get a non
    loopback IPv4 address, then a non loopback IPv6 address, and if it can't
    find both, it will use the local address.

  2. On top of the host shebangs supported, which include #local# and
    #[interface name]# (in your case #eth0#), which help create a standard
    configuration across nodes without needing specific ones per node, I have
    added #non_loopback#, #non_loopback:ipv4# and #non_loopback:ipv6#.

I pushed this to master, can you give it a go?

cheers,
shay.banon

On Thu, May 20, 2010 at 9:33 PM, tfreitas tfreitas@gmail.com wrote:

My ifconfig is:

eth0 Link encap:Ethernet HWaddr 00:0f:fe:02:ee:e5
inet addr:10.3.1.48 Bcast:10.3.255.255 Mask:255.255.0.0
inet6 addr: fe80::20f:feff:fe02:eee5/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:101862 errors:0 dropped:0 overruns:0 frame:0
TX packets:28375 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:43398354 (43.3 MB) TX bytes:5090313 (5.0 MB)
Interrupt:19

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:10 errors:0 dropped:0 overruns:0 frame:0
TX packets:10 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:688 (688.0 B) TX bytes:688 (688.0 B)

When I configure elasticsearch.yml with
network:
host: 10.3.1.48

Everything is OK

On May 20, 12:11 pm, Shay Banon shay.ba...@elasticsearch.com wrote:

Hi,

This is strange, as you can see, the publish address of the transport
is
127.0.0.1, which means if you start a node on another machine, they will
not
talk to each other. Can you send your ifconfig?

cheers,
shay.banon

On Thu, May 20, 2010 at 1:54 AM, tfreitas tfrei...@gmail.com wrote:

This is the log:


[18:23:13,577][INFO ][node ] [Nitro]
{ElasticSearch/0.7.1}[7138]: Initializing ...
[18:23:13,597][INFO ][plugins ] [Nitro] Loaded []
[18:23:15,243][DEBUG][threadpool.cached ] [Nitro] Initializing
cached thread pool with keep_alive[1m], scheduled_size[20]
[18:23:15,390][DEBUG][discovery.zen.ping.multicast] [Nitro] Using
group [224.2.2.4], with port [54328], ttl [3], and address [null]
[18:23:15,396][DEBUG][discovery.zen ] [Nitro] Using
initial_ping_timeout [3s]
[18:23:15,399][DEBUG][discovery.zen.fd ] [Nitro] Master FD
uses ping_interval [1s], ping_timeout [30s], ping_retries [3]
[18:23:15,415][DEBUG][discovery.zen.fd ] [Nitro] Nodes FD uses
ping_interval [1s], ping_timeout [30s], ping_retries [3]
[18:23:15,556][DEBUG][monitor.memory.alpha ] [Nitro]
interval[500ms], upper_memory_threshold[0.8],
lower_memory_threshold[0.5],
translog_number_of_operations_threshold[5000]
[18:23:15,893][DEBUG][indices.recovery.throttler] [Nitro]
concurrent_recoveries [1], concurrent_streams [1] interval [100ms]
[18:23:15,895][INFO ][node ] [Nitro]
{ElasticSearch/0.7.1}[7138]: Initialized
[18:23:15,895][INFO ][node ] [Nitro]
{ElasticSearch/0.7.1}[7138]: Starting ...
[18:23:15,995][DEBUG][netty.channel.socket.nio.NioProviderMetadata]
Using the autodetected NIO constraint level: 0
[18:23:16,185][DEBUG][transport.netty ] [Nitro] Bound to
address [/0:0:0:0:0:0:0:0:9300]
[18:23:16,187][INFO ][transport ] [Nitro]
bound_address[inet[/0:0:0:0:0:0:0:0:9300]], publish_address[inet[Tony/
127.0.1.1:9300]]
[18:23:16,268][ERROR][bootstrap ] [Nitro]
{ElasticSearch/0.7.1}: [31mStartup Failed ... [0m

  • DiscoveryException[Failed to setup multicast socket]
    SocketException[bad argument for IP_MULTICAST_IF: address not
    bound

to any interface]
[18:23:16,270][DEBUG][bootstrap ] [Nitro] Exception
org.elasticsearch.discovery.DiscoveryException: Failed to setup
multicast socket
at

org.elasticsearch.discovery.zen.ping.multicast.MulticastZenPing.doStart(MulticastZenPing.java:

  1. at

org.elasticsearch.util.component.AbstractLifecycleComponent.start(AbstractLifecycleComponent.java:

  1. at

org.elasticsearch.discovery.zen.ping.ZenPingService.doStart(ZenPingService.java:

  1. at

org.elasticsearch.util.component.AbstractLifecycleComponent.start(AbstractLifecycleComponent.java:

  1. at
    org.elasticsearch.discovery.zen.ZenDiscovery.doStart(ZenDiscovery.java:
  2. at

org.elasticsearch.util.component.AbstractLifecycleComponent.start(AbstractLifecycleComponent.java:

  1. at

org.elasticsearch.discovery.DiscoveryService.doStart(DiscoveryService.java:

  1. at

org.elasticsearch.util.component.AbstractLifecycleComponent.start(AbstractLifecycleComponent.java:

  1. at
    org.elasticsearch.node.internal.InternalNode.start(InternalNode.java:
  2. at
    org.elasticsearch.bootstrap.Bootstrap.start(Bootstrap.java:115)
   at

org.elasticsearch.bootstrap.Bootstrap.main(Bootstrap.java:168)

Caused by: java.net.SocketException: bad argument for IP_MULTICAST_IF:
address not bound to any interface
at java.net.PlainDatagramSocketImpl.socketSetOption(Native
Method)

   at

java.net.PlainDatagramSocketImpl.setOption(PlainDatagramSocketImpl.java:

  1. at
    java.net.MulticastSocket.setInterface(MulticastSocket.java:424)
   at

org.elasticsearch.discovery.zen.ping.multicast.MulticastZenPing.doStart(MulticastZenPing.java:

  1. ... 10 more
    [18:23:16,296][INFO ][node ] [Nitro]
    {ElasticSearch/0.7.1}[7138]: Stopping ...
    [18:23:16,319][INFO ][node ] [Nitro]
    {ElasticSearch/0.7.1}[7138]: Stopped
    [18:23:16,319][INFO ][node ] [Nitro]
    {ElasticSearch/0.7.1}[7138]: Closing ...
    [18:23:16,323][DEBUG][threadpool.cached ] [Nitro] Shutting down
    cached thread pool
    [18:23:16,338][INFO ][node ] [Nitro]
    {ElasticSearch/0.7.1}[7138]: Closed

On May 19, 6:08 pm, Shay Banon shay.ba...@elasticsearch.com wrote:

Hi,

First, can you set bootstrap to DEBUG level, and attache the log?
Basically, open the logging.yml file and replace the header with
this:

rootLogger: INFO, console, file
logger:

log action execution errors for easier debugging

action : DEBUG
bootstrap: DEBUG

Second, there is a new discovery module called zen, and by
default, it

uses multicast discovery. The exception would help me understand
where

this

is coming from...

Thanks,
shay.banon

On Thu, May 20, 2010 at 1:03 AM, tfreitas tfrei...@gmail.com
wrote:

Hi

When I test ES 0.7.1 with zero configuration (elasticsearch.yml
empty)

This error occurs

[17:26:45,627] [ERROR] [bootstrap] [Duquesne, Jacques] ()
ElasticSearch/0.7.1: Startup Failed ...

  • DiscoveryException [Failed to setup multicast socket]
    SocketException [bad argument for IP_MULTICAST_IF: Not bound to Any
    address interface]

I use Ubuntu 9.10

In previous versions always work with zero configuration


(tfreitas) #7

ok, between Friday and Monday I will try to master and tell you

Thanks

On May 20, 3:35 pm, Shay Banon shay.ba...@elasticsearch.com wrote:

I think the problem is with the default address chosen for the "publish"
address (the external address of the node). Seems like when I call for the
local address in elasticsearch, in your case, it returns lo instead of eth0.

So, I have made the following changes (and by the way, usually this
indicates wrong network settings on the os level):

  1. The publish address, when not set, will now first try to get a non
    loopback IPv4 address, then a non loopback IPv6 address, and if it can't
    find both, it will use the local address.

  2. On top of the host shebangs supported, which include #local# and
    #[interface name]# (in your case #eth0#), which help create a standard
    configuration across nodes without needing specific ones per node, I have
    added #non_loopback#, #non_loopback:ipv4# and #non_loopback:ipv6#.

I pushed this to master, can you give it a go?

cheers,
shay.banon

On Thu, May 20, 2010 at 9:33 PM, tfreitas tfrei...@gmail.com wrote:

My ifconfig is:

eth0 Link encap:Ethernet HWaddr 00:0f:fe:02:ee:e5
inet addr:10.3.1.48 Bcast:10.3.255.255 Mask:255.255.0.0
inet6 addr: fe80::20f:feff:fe02:eee5/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:101862 errors:0 dropped:0 overruns:0 frame:0
TX packets:28375 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:43398354 (43.3 MB) TX bytes:5090313 (5.0 MB)
Interrupt:19

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:10 errors:0 dropped:0 overruns:0 frame:0
TX packets:10 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:688 (688.0 B) TX bytes:688 (688.0 B)

When I configure elasticsearch.yml with
network:
host: 10.3.1.48

Everything is OK

On May 20, 12:11 pm, Shay Banon shay.ba...@elasticsearch.com wrote:

Hi,

This is strange, as you can see, the publish address of the transport
is
127.0.0.1, which means if you start a node on another machine, they will
not
talk to each other. Can you send your ifconfig?

cheers,
shay.banon

On Thu, May 20, 2010 at 1:54 AM, tfreitas tfrei...@gmail.com wrote:

This is the log:


[18:23:13,577][INFO ][node ] [Nitro]
{ElasticSearch/0.7.1}[7138]: Initializing ...
[18:23:13,597][INFO ][plugins ] [Nitro] Loaded []
[18:23:15,243][DEBUG][threadpool.cached ] [Nitro] Initializing
cached thread pool with keep_alive[1m], scheduled_size[20]
[18:23:15,390][DEBUG][discovery.zen.ping.multicast] [Nitro] Using
group [224.2.2.4], with port [54328], ttl [3], and address [null]
[18:23:15,396][DEBUG][discovery.zen ] [Nitro] Using
initial_ping_timeout [3s]
[18:23:15,399][DEBUG][discovery.zen.fd ] [Nitro] Master FD
uses ping_interval [1s], ping_timeout [30s], ping_retries [3]
[18:23:15,415][DEBUG][discovery.zen.fd ] [Nitro] Nodes FD uses
ping_interval [1s], ping_timeout [30s], ping_retries [3]
[18:23:15,556][DEBUG][monitor.memory.alpha ] [Nitro]
interval[500ms], upper_memory_threshold[0.8],
lower_memory_threshold[0.5],
translog_number_of_operations_threshold[5000]
[18:23:15,893][DEBUG][indices.recovery.throttler] [Nitro]
concurrent_recoveries [1], concurrent_streams [1] interval [100ms]
[18:23:15,895][INFO ][node ] [Nitro]
{ElasticSearch/0.7.1}[7138]: Initialized
[18:23:15,895][INFO ][node ] [Nitro]
{ElasticSearch/0.7.1}[7138]: Starting ...
[18:23:15,995][DEBUG][netty.channel.socket.nio.NioProviderMetadata]
Using the autodetected NIO constraint level: 0
[18:23:16,185][DEBUG][transport.netty ] [Nitro] Bound to
address [/0:0:0:0:0:0:0:0:9300]
[18:23:16,187][INFO ][transport ] [Nitro]
bound_address[inet[/0:0:0:0:0:0:0:0:9300]], publish_address[inet[Tony/
127.0.1.1:9300]]
[18:23:16,268][ERROR][bootstrap ] [Nitro]
{ElasticSearch/0.7.1}: [31mStartup Failed ... [0m

  • DiscoveryException[Failed to setup multicast socket]
    SocketException[bad argument for IP_MULTICAST_IF: address not
    bound

to any interface]
[18:23:16,270][DEBUG][bootstrap ] [Nitro] Exception
org.elasticsearch.discovery.DiscoveryException: Failed to setup
multicast socket
at

org.elasticsearch.discovery.zen.ping.multicast.MulticastZenPing.doStart(MulticastZenPing.java:

  1. at

org.elasticsearch.util.component.AbstractLifecycleComponent.start(AbstractLifecycleComponent.java:

  1. at

org.elasticsearch.discovery.zen.ping.ZenPingService.doStart(ZenPingService.java:

  1. at

org.elasticsearch.util.component.AbstractLifecycleComponent.start(AbstractLifecycleComponent.java:

  1. at
    org.elasticsearch.discovery.zen.ZenDiscovery.doStart(ZenDiscovery.java:
  2. at

org.elasticsearch.util.component.AbstractLifecycleComponent.start(AbstractLifecycleComponent.java:

  1. at

org.elasticsearch.discovery.DiscoveryService.doStart(DiscoveryService.java:

  1. at

org.elasticsearch.util.component.AbstractLifecycleComponent.start(AbstractLifecycleComponent.java:

  1. at
    org.elasticsearch.node.internal.InternalNode.start(InternalNode.java:
  2. at
    org.elasticsearch.bootstrap.Bootstrap.start(Bootstrap.java:115)
   at

org.elasticsearch.bootstrap.Bootstrap.main(Bootstrap.java:168)

Caused by: java.net.SocketException: bad argument for IP_MULTICAST_IF:
address not bound to any interface
at java.net.PlainDatagramSocketImpl.socketSetOption(Native
Method)

   at

java.net.PlainDatagramSocketImpl.setOption(PlainDatagramSocketImpl.java:

  1. at
    java.net.MulticastSocket.setInterface(MulticastSocket.java:424)
   at

org.elasticsearch.discovery.zen.ping.multicast.MulticastZenPing.doStart(MulticastZenPing.java:

  1. ... 10 more
    [18:23:16,296][INFO ][node ] [Nitro]
    {ElasticSearch/0.7.1}[7138]: Stopping ...
    [18:23:16,319][INFO ][node ] [Nitro]
    {ElasticSearch/0.7.1}[7138]: Stopped
    [18:23:16,319][INFO ][node ] [Nitro]
    {ElasticSearch/0.7.1}[7138]: Closing ...
    [18:23:16,323][DEBUG][threadpool.cached ] [Nitro] Shutting down
    cached thread pool
    [18:23:16,338][INFO ][node ] [Nitro]
    {ElasticSearch/0.7.1}[7138]: Closed

On May 19, 6:08 pm, Shay Banon shay.ba...@elasticsearch.com wrote:

Hi,

First, can you set bootstrap to DEBUG level, and attache the log?
Basically, open the logging.yml file and replace the header with
this:

rootLogger: INFO, console, file
logger:

log action execution errors for easier debugging

action : DEBUG
bootstrap: DEBUG

Second, there is a new discovery module called zen, and by
default, it

uses multicast discovery. The exception would help me understand
where

this

is coming from...

Thanks,
shay.banon

On Thu, May 20, 2010 at 1:03 AM, tfreitas tfrei...@gmail.com
wrote:

Hi

When I test ES 0.7.1 with zero configuration (elasticsearch.yml
empty)

This error occurs

[17:26:45,627] [ERROR] [bootstrap] [Duquesne, Jacques] ()
ElasticSearch/0.7.1: Startup Failed ...

  • DiscoveryException [Failed to setup multicast socket]
    SocketException [bad argument for IP_MULTICAST_IF: Not bound to Any
    address interface]

I use Ubuntu 9.10

In previous versions always work with zero configuration


(Shay Banon) #8

Thanks for that!. And to all elasticsearch users out there, if you have a
free 10 minutes, I would love if you can give master a go on your
environment and see if vanilla configuration works for you with the change
the default to the first non loopback address (I am concerned about ipvX
possible problems). Though this can easily be overridden in the
configuration, my aim is to get the best OOB experience for users. Thanks!

On Thu, May 20, 2010 at 10:51 PM, tfreitas tfreitas@gmail.com wrote:

ok, between Friday and Monday I will try to master and tell you

Thanks

On May 20, 3:35 pm, Shay Banon shay.ba...@elasticsearch.com wrote:

I think the problem is with the default address chosen for the "publish"
address (the external address of the node). Seems like when I call for
the
local address in elasticsearch, in your case, it returns lo instead of
eth0.

So, I have made the following changes (and by the way, usually this
indicates wrong network settings on the os level):

  1. The publish address, when not set, will now first try to get a non
    loopback IPv4 address, then a non loopback IPv6 address, and if it can't
    find both, it will use the local address.

  2. On top of the host shebangs supported, which include #local# and
    #[interface name]# (in your case #eth0#), which help create a standard
    configuration across nodes without needing specific ones per node, I have
    added #non_loopback#, #non_loopback:ipv4# and #non_loopback:ipv6#.

I pushed this to master, can you give it a go?

cheers,
shay.banon

On Thu, May 20, 2010 at 9:33 PM, tfreitas tfrei...@gmail.com wrote:

My ifconfig is:

eth0 Link encap:Ethernet HWaddr 00:0f:fe:02:ee:e5
inet addr:10.3.1.48 Bcast:10.3.255.255 Mask:255.255.0.0
inet6 addr: fe80::20f:feff:fe02:eee5/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:101862 errors:0 dropped:0 overruns:0 frame:0
TX packets:28375 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:43398354 (43.3 MB) TX bytes:5090313 (5.0 MB)
Interrupt:19

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:10 errors:0 dropped:0 overruns:0 frame:0
TX packets:10 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:688 (688.0 B) TX bytes:688 (688.0 B)

When I configure elasticsearch.yml with
network:
host: 10.3.1.48

Everything is OK

On May 20, 12:11 pm, Shay Banon shay.ba...@elasticsearch.com wrote:

Hi,

This is strange, as you can see, the publish address of the
transport

is

127.0.0.1, which means if you start a node on another machine, they
will

not

talk to each other. Can you send your ifconfig?

cheers,
shay.banon

On Thu, May 20, 2010 at 1:54 AM, tfreitas tfrei...@gmail.com
wrote:

This is the log:


[18:23:13,577][INFO ][node ] [Nitro]
{ElasticSearch/0.7.1}[7138]: Initializing ...
[18:23:13,597][INFO ][plugins ] [Nitro] Loaded []
[18:23:15,243][DEBUG][threadpool.cached ] [Nitro]
Initializing

cached thread pool with keep_alive[1m], scheduled_size[20]
[18:23:15,390][DEBUG][discovery.zen.ping.multicast] [Nitro] Using
group [224.2.2.4], with port [54328], ttl [3], and address [null]
[18:23:15,396][DEBUG][discovery.zen ] [Nitro] Using
initial_ping_timeout [3s]
[18:23:15,399][DEBUG][discovery.zen.fd ] [Nitro] Master FD
uses ping_interval [1s], ping_timeout [30s], ping_retries [3]
[18:23:15,415][DEBUG][discovery.zen.fd ] [Nitro] Nodes FD
uses

ping_interval [1s], ping_timeout [30s], ping_retries [3]
[18:23:15,556][DEBUG][monitor.memory.alpha ] [Nitro]
interval[500ms], upper_memory_threshold[0.8],
lower_memory_threshold[0.5],
translog_number_of_operations_threshold[5000]
[18:23:15,893][DEBUG][indices.recovery.throttler] [Nitro]
concurrent_recoveries [1], concurrent_streams [1] interval [100ms]
[18:23:15,895][INFO ][node ] [Nitro]
{ElasticSearch/0.7.1}[7138]: Initialized
[18:23:15,895][INFO ][node ] [Nitro]
{ElasticSearch/0.7.1}[7138]: Starting ...
[18:23:15,995][DEBUG][netty.channel.socket.nio.NioProviderMetadata]
Using the autodetected NIO constraint level: 0
[18:23:16,185][DEBUG][transport.netty ] [Nitro] Bound to
address [/0:0:0:0:0:0:0:0:9300]
[18:23:16,187][INFO ][transport ] [Nitro]
bound_address[inet[/0:0:0:0:0:0:0:0:9300]],
publish_address[inet[Tony/

127.0.1.1:9300]]
[18:23:16,268][ERROR][bootstrap ] [Nitro]
{ElasticSearch/0.7.1}: [31mStartup Failed ... [0m

  • DiscoveryException[Failed to setup multicast socket]
    SocketException[bad argument for IP_MULTICAST_IF: address
    not

bound

to any interface]
[18:23:16,270][DEBUG][bootstrap ] [Nitro] Exception
org.elasticsearch.discovery.DiscoveryException: Failed to setup
multicast socket
at

org.elasticsearch.discovery.zen.ping.multicast.MulticastZenPing.doStart(MulticastZenPing.java:

  1. at

org.elasticsearch.util.component.AbstractLifecycleComponent.start(AbstractLifecycleComponent.java:

  1. at

org.elasticsearch.discovery.zen.ping.ZenPingService.doStart(ZenPingService.java:

  1. at

org.elasticsearch.util.component.AbstractLifecycleComponent.start(AbstractLifecycleComponent.java:

  1. at

org.elasticsearch.discovery.zen.ZenDiscovery.doStart(ZenDiscovery.java:

  1. at

org.elasticsearch.util.component.AbstractLifecycleComponent.start(AbstractLifecycleComponent.java:

  1. at

org.elasticsearch.discovery.DiscoveryService.doStart(DiscoveryService.java:

  1. at

org.elasticsearch.util.component.AbstractLifecycleComponent.start(AbstractLifecycleComponent.java:

  1. at

org.elasticsearch.node.internal.InternalNode.start(InternalNode.java:

  1. at
    org.elasticsearch.bootstrap.Bootstrap.start(Bootstrap.java:115)
   at

org.elasticsearch.bootstrap.Bootstrap.main(Bootstrap.java:168)

Caused by: java.net.SocketException: bad argument for
IP_MULTICAST_IF:

address not bound to any interface
at java.net.PlainDatagramSocketImpl.socketSetOption(Native
Method)

   at

java.net.PlainDatagramSocketImpl.setOption(PlainDatagramSocketImpl.java:

  1. at
    java.net.MulticastSocket.setInterface(MulticastSocket.java:424)
   at

org.elasticsearch.discovery.zen.ping.multicast.MulticastZenPing.doStart(MulticastZenPing.java:

  1. ... 10 more
    [18:23:16,296][INFO ][node ] [Nitro]
    {ElasticSearch/0.7.1}[7138]: Stopping ...
    [18:23:16,319][INFO ][node ] [Nitro]
    {ElasticSearch/0.7.1}[7138]: Stopped
    [18:23:16,319][INFO ][node ] [Nitro]
    {ElasticSearch/0.7.1}[7138]: Closing ...
    [18:23:16,323][DEBUG][threadpool.cached ] [Nitro] Shutting
    down

cached thread pool
[18:23:16,338][INFO ][node ] [Nitro]
{ElasticSearch/0.7.1}[7138]: Closed


On May 19, 6:08 pm, Shay Banon shay.ba...@elasticsearch.com
wrote:

Hi,

First, can you set bootstrap to DEBUG level, and attache the
log?

Basically, open the logging.yml file and replace the header with
this:

rootLogger: INFO, console, file
logger:

log action execution errors for easier debugging

action : DEBUG
bootstrap: DEBUG

Second, there is a new discovery module called zen, and by
default, it

uses multicast discovery. The exception would help me understand
where

this

is coming from...

Thanks,
shay.banon

On Thu, May 20, 2010 at 1:03 AM, tfreitas tfrei...@gmail.com
wrote:

Hi

When I test ES 0.7.1 with zero configuration
(elasticsearch.yml

empty)

This error occurs

[17:26:45,627] [ERROR] [bootstrap] [Duquesne, Jacques] ()
ElasticSearch/0.7.1: Startup Failed ...

  • DiscoveryException [Failed to setup multicast socket]
    SocketException [bad argument for IP_MULTICAST_IF: Not bound to
    Any

address interface]

I use Ubuntu 9.10

In previous versions always work with zero configuration


(tfreitas) #9

Hi shay

I tried with master today, everything is ok

my ifconfig:
eth0 Link encap:Ethernet HWaddr 00:0f:fe:02:ee:e5
inet addr:10.3.1.48 Bcast:10.3.255.255 Mask:255.255.0.0
inet6 addr: fe80::20f:feff:fe02:eee5/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:36259 errors:0 dropped:0 overruns:0 frame:0
TX packets:16465 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:21948807 (21.9 MB) TX bytes:2146439 (2.1 MB)
Interrupt:19

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:12501 errors:0 dropped:0 overruns:0 frame:0
TX packets:12501 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1400290 (1.4 MB) TX bytes:1400290 (1.4 MB)

the log in bootstrap

Thanks

On May 20, 6:41 pm, Shay Banon shay.ba...@elasticsearch.com wrote:

Thanks for that!. And to all elasticsearch users out there, if you have a
free 10 minutes, I would love if you can give master a go on your
environment and see if vanilla configuration works for you with the change
the default to the first non loopback address (I am concerned about ipvX
possible problems). Though this can easily be overridden in the
configuration, my aim is to get the best OOB experience for users. Thanks!

On Thu, May 20, 2010 at 10:51 PM, tfreitas tfrei...@gmail.com wrote:

ok, between Friday and Monday I will try to master and tell you

Thanks

On May 20, 3:35 pm, Shay Banon shay.ba...@elasticsearch.com wrote:

I think the problem is with the default address chosen for the "publish"
address (the external address of the node). Seems like when I call for
the
local address in elasticsearch, in your case, it returns lo instead of
eth0.

So, I have made the following changes (and by the way, usually this
indicates wrong network settings on the os level):

  1. The publish address, when not set, will now first try to get a non
    loopback IPv4 address, then a non loopback IPv6 address, and if it can't
    find both, it will use the local address.
  1. On top of the host shebangs supported, which include #local# and
    #[interface name]# (in your case #eth0#), which help create a standard
    configuration across nodes without needing specific ones per node, I have
    added #non_loopback#, #non_loopback:ipv4# and #non_loopback:ipv6#.

I pushed this to master, can you give it a go?

cheers,
shay.banon

On Thu, May 20, 2010 at 9:33 PM, tfreitas tfrei...@gmail.com wrote:

My ifconfig is:

eth0 Link encap:Ethernet HWaddr 00:0f:fe:02:ee:e5
inet addr:10.3.1.48 Bcast:10.3.255.255 Mask:255.255.0.0
inet6 addr: fe80::20f:feff:fe02:eee5/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:101862 errors:0 dropped:0 overruns:0 frame:0
TX packets:28375 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:43398354 (43.3 MB) TX bytes:5090313 (5.0 MB)
Interrupt:19

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:10 errors:0 dropped:0 overruns:0 frame:0
TX packets:10 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:688 (688.0 B) TX bytes:688 (688.0 B)

When I configure elasticsearch.yml with
network:
host: 10.3.1.48

Everything is OK

On May 20, 12:11 pm, Shay Banon shay.ba...@elasticsearch.com wrote:

Hi,

This is strange, as you can see, the publish address of the
transport

is

127.0.0.1, which means if you start a node on another machine, they
will

not

talk to each other. Can you send your ifconfig?

cheers,
shay.banon

On Thu, May 20, 2010 at 1:54 AM, tfreitas tfrei...@gmail.com
wrote:

This is the log:


[18:23:13,577][INFO ][node ] [Nitro]
{ElasticSearch/0.7.1}[7138]: Initializing ...
[18:23:13,597][INFO ][plugins ] [Nitro] Loaded []
[18:23:15,243][DEBUG][threadpool.cached ] [Nitro]
Initializing

cached thread pool with keep_alive[1m], scheduled_size[20]
[18:23:15,390][DEBUG][discovery.zen.ping.multicast] [Nitro] Using
group [224.2.2.4], with port [54328], ttl [3], and address [null]
[18:23:15,396][DEBUG][discovery.zen ] [Nitro] Using
initial_ping_timeout [3s]
[18:23:15,399][DEBUG][discovery.zen.fd ] [Nitro] Master FD
uses ping_interval [1s], ping_timeout [30s], ping_retries [3]
[18:23:15,415][DEBUG][discovery.zen.fd ] [Nitro] Nodes FD
uses

ping_interval [1s], ping_timeout [30s], ping_retries [3]
[18:23:15,556][DEBUG][monitor.memory.alpha ] [Nitro]
interval[500ms], upper_memory_threshold[0.8],
lower_memory_threshold[0.5],
translog_number_of_operations_threshold[5000]
[18:23:15,893][DEBUG][indices.recovery.throttler] [Nitro]
concurrent_recoveries [1], concurrent_streams [1] interval [100ms]
[18:23:15,895][INFO ][node ] [Nitro]
{ElasticSearch/0.7.1}[7138]: Initialized
[18:23:15,895][INFO ][node ] [Nitro]
{ElasticSearch/0.7.1}[7138]: Starting ...
[18:23:15,995][DEBUG][netty.channel.socket.nio.NioProviderMetadata]
Using the autodetected NIO constraint level: 0
[18:23:16,185][DEBUG][transport.netty ] [Nitro] Bound to
address [/0:0:0:0:0:0:0:0:9300]
[18:23:16,187][INFO ][transport ] [Nitro]
bound_address[inet[/0:0:0:0:0:0:0:0:9300]],
publish_address[inet[Tony/

127.0.1.1:9300]]
[18:23:16,268][ERROR][bootstrap ] [Nitro]
{ElasticSearch/0.7.1}: [31mStartup Failed ... [0m

  • DiscoveryException[Failed to setup multicast socket]
    SocketException[bad argument for IP_MULTICAST_IF: address
    not

bound

to any interface]
[18:23:16,270][DEBUG][bootstrap ] [Nitro] Exception
org.elasticsearch.discovery.DiscoveryException: Failed to setup
multicast socket
at

org.elasticsearch.discovery.zen.ping.multicast.MulticastZenPing.doStart(Mul ticastZenPing.java:

  1. at

org.elasticsearch.util.component.AbstractLifecycleComponent.start(AbstractL ifecycleComponent.java:

  1. at

org.elasticsearch.discovery.zen.ping.ZenPingService.doStart(ZenPingService. java:

  1. at

org.elasticsearch.util.component.AbstractLifecycleComponent.start(AbstractL ifecycleComponent.java:

  1. at

org.elasticsearch.discovery.zen.ZenDiscovery.doStart(ZenDiscovery.java:

  1. at

org.elasticsearch.util.component.AbstractLifecycleComponent.start(AbstractL ifecycleComponent.java:

  1. at

org.elasticsearch.discovery.DiscoveryService.doStart(DiscoveryService.java:

  1. at

org.elasticsearch.util.component.AbstractLifecycleComponent.start(AbstractL ifecycleComponent.java:

  1. at

org.elasticsearch.node.internal.InternalNode.start(InternalNode.java:

  1. at
    org.elasticsearch.bootstrap.Bootstrap.start(Bootstrap.java:115)
   at

org.elasticsearch.bootstrap.Bootstrap.main(Bootstrap.java:168)

Caused by: java.net.SocketException: bad argument for
IP_MULTICAST_IF:

address not bound to any interface
at java.net.PlainDatagramSocketImpl.socketSetOption(Native
Method)

   at

java.net.PlainDatagramSocketImpl.setOption(PlainDatagramSocketImpl.java:

  1. at
    java.net.MulticastSocket.setInterface(MulticastSocket.java:424)
   at

org.elasticsearch.discovery.zen.ping.multicast.MulticastZenPing.doStart(Mul ticastZenPing.java:

  1. ... 10 more
    [18:23:16,296][INFO ][node ] [Nitro]
    {ElasticSearch/0.7.1}[7138]: Stopping ...
    [18:23:16,319][INFO ][node ] [Nitro]
    {ElasticSearch/0.7.1}[7138]: Stopped
    [18:23:16,319][INFO ][node ] [Nitro]
    {ElasticSearch/0.7.1}[7138]: Closing ...
    [18:23:16,323][DEBUG][threadpool.cached ] [Nitro] Shutting
    down

cached thread pool
[18:23:16,338][INFO ][node ] [Nitro]
{ElasticSearch/0.7.1}[7138]: Closed


On May 19, 6:08 pm, Shay Banon shay.ba...@elasticsearch.com
wrote:

Hi,

First, can you set bootstrap to DEBUG level, and attache the
log?

Basically, open the logging.yml file and replace the header with
this:

rootLogger: INFO, console, file
logger:

log action execution errors for easier debugging

action : DEBUG
bootstrap: DEBUG

Second, there is a new discovery module called zen, and by
default, it

uses multicast discovery. The exception would help me understand
where

this

is coming from...

Thanks,
shay.banon

On Thu, May 20, 2010 at 1:03 AM, tfreitas tfrei...@gmail.com
wrote:

Hi

When I test ES 0.7.1 with zero configuration
(elasticsearch.yml

empty)

This error occurs

[17:26:45,627] [ERROR] [bootstrap] [Duquesne, Jacques] ()
ElasticSearch/0.7.1: Startup Failed ...

  • DiscoveryException [Failed to setup multicast socket]
    SocketException [bad argument for IP_MULTICAST_IF: Not bound to
    Any

address interface]

I use Ubuntu 9.10

...

read more »


(Shay Banon) #10

cool. Just verifying that you did not set the network.host setting with
master?

On Tue, May 25, 2010 at 1:58 AM, tfreitas tfreitas@gmail.com wrote:

Hi shay

I tried with master today, everything is ok

my ifconfig:
eth0 Link encap:Ethernet HWaddr 00:0f:fe:02:ee:e5
inet addr:10.3.1.48 Bcast:10.3.255.255 Mask:255.255.0.0
inet6 addr: fe80::20f:feff:fe02:eee5/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:36259 errors:0 dropped:0 overruns:0 frame:0
TX packets:16465 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:21948807 (21.9 MB) TX bytes:2146439 (2.1 MB)
Interrupt:19

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:12501 errors:0 dropped:0 overruns:0 frame:0
TX packets:12501 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1400290 (1.4 MB) TX bytes:1400290 (1.4 MB)

the log in bootstrap
http://gist.github.com/412532

Thanks

On May 20, 6:41 pm, Shay Banon shay.ba...@elasticsearch.com wrote:

Thanks for that!. And to all elasticsearch users out there, if you have a
free 10 minutes, I would love if you can give master a go on your
environment and see if vanilla configuration works for you with the
change
the default to the first non loopback address (I am concerned about ipvX
possible problems). Though this can easily be overridden in the
configuration, my aim is to get the best OOB experience for users.
Thanks!

On Thu, May 20, 2010 at 10:51 PM, tfreitas tfrei...@gmail.com wrote:

ok, between Friday and Monday I will try to master and tell you

Thanks

On May 20, 3:35 pm, Shay Banon shay.ba...@elasticsearch.com wrote:

I think the problem is with the default address chosen for the
"publish"

address (the external address of the node). Seems like when I call
for

the

local address in elasticsearch, in your case, it returns lo instead
of

eth0.

So, I have made the following changes (and by the way, usually this
indicates wrong network settings on the os level):

  1. The publish address, when not set, will now first try to get a non
    loopback IPv4 address, then a non loopback IPv6 address, and if it
    can't

find both, it will use the local address.

  1. On top of the host shebangs supported, which include #local# and
    #[interface name]# (in your case #eth0#), which help create a
    standard

configuration across nodes without needing specific ones per node, I
have

added #non_loopback#, #non_loopback:ipv4# and #non_loopback:ipv6#.

I pushed this to master, can you give it a go?

cheers,
shay.banon

On Thu, May 20, 2010 at 9:33 PM, tfreitas tfrei...@gmail.com
wrote:

My ifconfig is:

eth0 Link encap:Ethernet HWaddr 00:0f:fe:02:ee:e5
inet addr:10.3.1.48 Bcast:10.3.255.255 Mask:255.255.0.0
inet6 addr: fe80::20f:feff:fe02:eee5/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:101862 errors:0 dropped:0 overruns:0 frame:0
TX packets:28375 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:43398354 (43.3 MB) TX bytes:5090313 (5.0 MB)
Interrupt:19

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:10 errors:0 dropped:0 overruns:0 frame:0
TX packets:10 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:688 (688.0 B) TX bytes:688 (688.0 B)

When I configure elasticsearch.yml with
network:
host: 10.3.1.48

Everything is OK

On May 20, 12:11 pm, Shay Banon shay.ba...@elasticsearch.com
wrote:

Hi,

This is strange, as you can see, the publish address of the
transport

is

127.0.0.1, which means if you start a node on another machine,
they

will

not

talk to each other. Can you send your ifconfig?

cheers,
shay.banon

On Thu, May 20, 2010 at 1:54 AM, tfreitas tfrei...@gmail.com
wrote:

This is the log:


[18:23:13,577][INFO ][node ] [Nitro]
{ElasticSearch/0.7.1}[7138]: Initializing ...
[18:23:13,597][INFO ][plugins ] [Nitro] Loaded
[]

[18:23:15,243][DEBUG][threadpool.cached ] [Nitro]
Initializing

cached thread pool with keep_alive[1m], scheduled_size[20]
[18:23:15,390][DEBUG][discovery.zen.ping.multicast] [Nitro]
Using

group [224.2.2.4], with port [54328], ttl [3], and address
[null]

[18:23:15,396][DEBUG][discovery.zen ] [Nitro] Using
initial_ping_timeout [3s]
[18:23:15,399][DEBUG][discovery.zen.fd ] [Nitro] Master
FD

uses ping_interval [1s], ping_timeout [30s], ping_retries [3]
[18:23:15,415][DEBUG][discovery.zen.fd ] [Nitro] Nodes
FD

uses

ping_interval [1s], ping_timeout [30s], ping_retries [3]
[18:23:15,556][DEBUG][monitor.memory.alpha ] [Nitro]
interval[500ms], upper_memory_threshold[0.8],
lower_memory_threshold[0.5],
translog_number_of_operations_threshold[5000]
[18:23:15,893][DEBUG][indices.recovery.throttler] [Nitro]
concurrent_recoveries [1], concurrent_streams [1] interval
[100ms]

[18:23:15,895][INFO ][node ] [Nitro]
{ElasticSearch/0.7.1}[7138]: Initialized
[18:23:15,895][INFO ][node ] [Nitro]
{ElasticSearch/0.7.1}[7138]: Starting ...

[18:23:15,995][DEBUG][netty.channel.socket.nio.NioProviderMetadata]

Using the autodetected NIO constraint level: 0
[18:23:16,185][DEBUG][transport.netty ] [Nitro] Bound
to

address [/0:0:0:0:0:0:0:0:9300]
[18:23:16,187][INFO ][transport ] [Nitro]
bound_address[inet[/0:0:0:0:0:0:0:0:9300]],
publish_address[inet[Tony/

127.0.1.1:9300]]
[18:23:16,268][ERROR][bootstrap ] [Nitro]
{ElasticSearch/0.7.1}: [31mStartup Failed ... [0m

  • DiscoveryException[Failed to setup multicast socket]
    SocketException[bad argument for IP_MULTICAST_IF:
    address

not

bound

to any interface]
[18:23:16,270][DEBUG][bootstrap ] [Nitro]
Exception

org.elasticsearch.discovery.DiscoveryException: Failed to setup
multicast socket
at

org.elasticsearch.discovery.zen.ping.multicast.MulticastZenPing.doStart(Mul
ticastZenPing.java:

  1. at

org.elasticsearch.util.component.AbstractLifecycleComponent.start(AbstractL
ifecycleComponent.java:

  1. at

org.elasticsearch.discovery.zen.ping.ZenPingService.doStart(ZenPingService.
java:

  1. at

org.elasticsearch.util.component.AbstractLifecycleComponent.start(AbstractL
ifecycleComponent.java:

  1. at

org.elasticsearch.discovery.zen.ZenDiscovery.doStart(ZenDiscovery.java:

  1. at

org.elasticsearch.util.component.AbstractLifecycleComponent.start(AbstractL
ifecycleComponent.java:

  1. at

org.elasticsearch.discovery.DiscoveryService.doStart(DiscoveryService.java:

  1. at

org.elasticsearch.util.component.AbstractLifecycleComponent.start(AbstractL
ifecycleComponent.java:

  1. at

org.elasticsearch.node.internal.InternalNode.start(InternalNode.java:

  1. at
    org.elasticsearch.bootstrap.Bootstrap.start(Bootstrap.java:115)
   at

org.elasticsearch.bootstrap.Bootstrap.main(Bootstrap.java:168)

Caused by: java.net.SocketException: bad argument for
IP_MULTICAST_IF:

address not bound to any interface
at
java.net.PlainDatagramSocketImpl.socketSetOption(Native

Method)

   at

java.net.PlainDatagramSocketImpl.setOption(PlainDatagramSocketImpl.java:

  1. at
    java.net.MulticastSocket.setInterface(MulticastSocket.java:424)
   at

org.elasticsearch.discovery.zen.ping.multicast.MulticastZenPing.doStart(Mul
ticastZenPing.java:

  1. ... 10 more
    [18:23:16,296][INFO ][node ] [Nitro]
    {ElasticSearch/0.7.1}[7138]: Stopping ...
    [18:23:16,319][INFO ][node ] [Nitro]
    {ElasticSearch/0.7.1}[7138]: Stopped
    [18:23:16,319][INFO ][node ] [Nitro]
    {ElasticSearch/0.7.1}[7138]: Closing ...
    [18:23:16,323][DEBUG][threadpool.cached ] [Nitro]
    Shutting

down

cached thread pool
[18:23:16,338][INFO ][node ] [Nitro]
{ElasticSearch/0.7.1}[7138]: Closed


On May 19, 6:08 pm, Shay Banon shay.ba...@elasticsearch.com
wrote:

Hi,

First, can you set bootstrap to DEBUG level, and attache
the

log?

Basically, open the logging.yml file and replace the header
with

this:

rootLogger: INFO, console, file
logger:

log action execution errors for easier debugging

action : DEBUG
bootstrap: DEBUG

Second, there is a new discovery module called zen, and by
default, it

uses multicast discovery. The exception would help me
understand

where

this

is coming from...

Thanks,
shay.banon

On Thu, May 20, 2010 at 1:03 AM, tfreitas <
tfrei...@gmail.com>

wrote:

Hi

When I test ES 0.7.1 with zero configuration
(elasticsearch.yml

empty)

This error occurs

[17:26:45,627] [ERROR] [bootstrap] [Duquesne, Jacques] ()
ElasticSearch/0.7.1: Startup Failed ...

  • DiscoveryException [Failed to setup multicast socket]
    SocketException [bad argument for IP_MULTICAST_IF: Not
    bound to

Any

address interface]

I use Ubuntu 9.10

...

read more »


(tfreitas) #11

yes, with zero configuration

On May 25, 2:42 pm, Shay Banon shay.ba...@elasticsearch.com wrote:

cool. Just verifying that you did not set the network.host setting with
master?

On Tue, May 25, 2010 at 1:58 AM, tfreitas tfrei...@gmail.com wrote:

Hi shay

I tried with master today, everything is ok

my ifconfig:
eth0 Link encap:Ethernet HWaddr 00:0f:fe:02:ee:e5
inet addr:10.3.1.48 Bcast:10.3.255.255 Mask:255.255.0.0
inet6 addr: fe80::20f:feff:fe02:eee5/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:36259 errors:0 dropped:0 overruns:0 frame:0
TX packets:16465 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:21948807 (21.9 MB) TX bytes:2146439 (2.1 MB)
Interrupt:19

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:12501 errors:0 dropped:0 overruns:0 frame:0
TX packets:12501 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1400290 (1.4 MB) TX bytes:1400290 (1.4 MB)

the log in bootstrap
http://gist.github.com/412532

Thanks

On May 20, 6:41 pm, Shay Banon shay.ba...@elasticsearch.com wrote:

Thanks for that!. And to all elasticsearch users out there, if you have a
free 10 minutes, I would love if you can give master a go on your
environment and see if vanilla configuration works for you with the
change
the default to the first non loopback address (I am concerned about ipvX
possible problems). Though this can easily be overridden in the
configuration, my aim is to get the best OOB experience for users.
Thanks!

On Thu, May 20, 2010 at 10:51 PM, tfreitas tfrei...@gmail.com wrote:

ok, between Friday and Monday I will try to master and tell you

Thanks

On May 20, 3:35 pm, Shay Banon shay.ba...@elasticsearch.com wrote:

I think the problem is with the default address chosen for the
"publish"

address (the external address of the node). Seems like when I call
for

the

local address in elasticsearch, in your case, it returns lo instead
of

eth0.

So, I have made the following changes (and by the way, usually this
indicates wrong network settings on the os level):

  1. The publish address, when not set, will now first try to get a non
    loopback IPv4 address, then a non loopback IPv6 address, and if it
    can't

find both, it will use the local address.

  1. On top of the host shebangs supported, which include #local# and
    #[interface name]# (in your case #eth0#), which help create a
    standard

configuration across nodes without needing specific ones per node, I
have

added #non_loopback#, #non_loopback:ipv4# and #non_loopback:ipv6#.

I pushed this to master, can you give it a go?

cheers,
shay.banon

On Thu, May 20, 2010 at 9:33 PM, tfreitas tfrei...@gmail.com
wrote:

My ifconfig is:

eth0 Link encap:Ethernet HWaddr 00:0f:fe:02:ee:e5
inet addr:10.3.1.48 Bcast:10.3.255.255 Mask:255.255.0.0
inet6 addr: fe80::20f:feff:fe02:eee5/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:101862 errors:0 dropped:0 overruns:0 frame:0
TX packets:28375 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:43398354 (43.3 MB) TX bytes:5090313 (5.0 MB)
Interrupt:19

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:10 errors:0 dropped:0 overruns:0 frame:0
TX packets:10 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:688 (688.0 B) TX bytes:688 (688.0 B)

When I configure elasticsearch.yml with
network:
host: 10.3.1.48

Everything is OK

On May 20, 12:11 pm, Shay Banon shay.ba...@elasticsearch.com
wrote:

Hi,

This is strange, as you can see, the publish address of the
transport

is

127.0.0.1, which means if you start a node on another machine,
they

will

not

talk to each other. Can you send your ifconfig?

cheers,
shay.banon

On Thu, May 20, 2010 at 1:54 AM, tfreitas tfrei...@gmail.com
wrote:

This is the log:


[18:23:13,577][INFO ][node ] [Nitro]
{ElasticSearch/0.7.1}[7138]: Initializing ...
[18:23:13,597][INFO ][plugins ] [Nitro] Loaded
[]

[18:23:15,243][DEBUG][threadpool.cached ] [Nitro]
Initializing

cached thread pool with keep_alive[1m], scheduled_size[20]
[18:23:15,390][DEBUG][discovery.zen.ping.multicast] [Nitro]
Using

group [224.2.2.4], with port [54328], ttl [3], and address
[null]

[18:23:15,396][DEBUG][discovery.zen ] [Nitro] Using
initial_ping_timeout [3s]
[18:23:15,399][DEBUG][discovery.zen.fd ] [Nitro] Master
FD

uses ping_interval [1s], ping_timeout [30s], ping_retries [3]
[18:23:15,415][DEBUG][discovery.zen.fd ] [Nitro] Nodes
FD

uses

ping_interval [1s], ping_timeout [30s], ping_retries [3]
[18:23:15,556][DEBUG][monitor.memory.alpha ] [Nitro]
interval[500ms], upper_memory_threshold[0.8],
lower_memory_threshold[0.5],
translog_number_of_operations_threshold[5000]
[18:23:15,893][DEBUG][indices.recovery.throttler] [Nitro]
concurrent_recoveries [1], concurrent_streams [1] interval
[100ms]

[18:23:15,895][INFO ][node ] [Nitro]
{ElasticSearch/0.7.1}[7138]: Initialized
[18:23:15,895][INFO ][node ] [Nitro]
{ElasticSearch/0.7.1}[7138]: Starting ...

[18:23:15,995][DEBUG][netty.channel.socket.nio.NioProviderMetadata]

Using the autodetected NIO constraint level: 0
[18:23:16,185][DEBUG][transport.netty ] [Nitro] Bound
to

address [/0:0:0:0:0:0:0:0:9300]
[18:23:16,187][INFO ][transport ] [Nitro]
bound_address[inet[/0:0:0:0:0:0:0:0:9300]],
publish_address[inet[Tony/

127.0.1.1:9300]]
[18:23:16,268][ERROR][bootstrap ] [Nitro]
{ElasticSearch/0.7.1}: [31mStartup Failed ... [0m

  • DiscoveryException[Failed to setup multicast socket]
    SocketException[bad argument for IP_MULTICAST_IF:
    address

not

bound

to any interface]
[18:23:16,270][DEBUG][bootstrap ] [Nitro]
Exception

org.elasticsearch.discovery.DiscoveryException: Failed to setup
multicast socket
at

org.elasticsearch.discovery.zen.ping.multicast.MulticastZenPing.doStart(Mul
ticastZenPing.java:

  1. at

org.elasticsearch.util.component.AbstractLifecycleComponent.start(AbstractL
ifecycleComponent.java:

  1. at

org.elasticsearch.discovery.zen.ping.ZenPingService.doStart(ZenPingService.
java:

  1. at

org.elasticsearch.util.component.AbstractLifecycleComponent.start(AbstractL
ifecycleComponent.java:

  1. at

org.elasticsearch.discovery.zen.ZenDiscovery.doStart(ZenDiscovery.java:

  1. at

org.elasticsearch.util.component.AbstractLifecycleComponent.start(AbstractL
ifecycleComponent.java:

  1. at

org.elasticsearch.discovery.DiscoveryService.doStart(DiscoveryService.java:

  1. at

org.elasticsearch.util.component.AbstractLifecycleComponent.start(AbstractL
ifecycleComponent.java:

  1. at

org.elasticsearch.node.internal.InternalNode.start(InternalNode.java:

  1. at
    org.elasticsearch.bootstrap.Bootstrap.start(Bootstrap.java:115)
   at

org.elasticsearch.bootstrap.Bootstrap.main(Bootstrap.java:168)

Caused by: java.net.SocketException: bad argument for
IP_MULTICAST_IF:

address not bound to any interface
at
java.net.PlainDatagramSocketImpl.socketSetOption(Native

Method)

   at

java.net.PlainDatagramSocketImpl.setOption(PlainDatagramSocketImpl.java:

  1. at
    java.net.MulticastSocket.setInterface(MulticastSocket.java:424)
   at

org.elasticsearch.discovery.zen.ping.multicast.MulticastZenPing.doStart(Mul
ticastZenPing.java:

  1. ... 10 more
    [18:23:16,296][INFO ][node ] [Nitro]
    {ElasticSearch/0.7.1}[7138]: Stopping ...
    [18:23:16,319][INFO ][node ] [Nitro]
    {ElasticSearch/0.7.1}[7138]: Stopped

...

read more »


(system) #12