Error in creating cluster with option persistentVolumeReclaimPolicy: Retain after upgrading from 1.0.1 to 1.1.2

After upgrading to 1.1.2 I got error from kubectl -n elastic-system logs -f statefulset.apps/elastic-operator about persistentVolumeReclaimPolicy is not a valid filed, and after removing persistentVolumeReclaimPolicy: Retain from my configuration it worked. the following is he volum configuration I used knowing that this configuration is working since 0.9 beta and also worked when I upgraded to 1.0.1, but only crashed after upgrading to 1.1.2

- metadata:
    name: elasticsearch-data
    persistentVolumeReclaimPolicy: Retain
    - ReadWriteOnce
        storage: 256Gi
    storageClassName: ebs-csi-gp2-sc

I do not know if this is a feature or a problem in the validator, but I think it worth mentioning, because we tend to retain the volumes and the default is delete.

VolumeClaimTemplates is a field containing an array of PersistentVolumeClaimSpec objects. PersistentVolumeClaimSpec objects do not have a field named persistentVolumeReclaimPolicy:

The StorageClass defines the reclaim policy -- which is set through the storageClassName field. You already have set this field to ebs-csi-gp2-sc so you should take a look at the definition of the ebs-csi-gp2-sc storage class to make sure it has the correct reclaimPolicy defined on it.

kubectl get sc ebs-csi-gp2-sc