Error index management Filebeat to Logstash

Hi, I have the following configuration: Filebeat 7.2.0 and Logstash 7.2.0.

ERROR instance/beat.go:877 Exiting: Index management requested but the Elasticsearch output is not configured/enabled

When I run the filebeat setup -e command, I get the following error:

#templatsetting all commented
#output.elasticsearch
#allcommented

output.logstash
host["192.168.1.104:5044"]



setup.ilm.enabled: false 
ilm.enabled: false 

Reading on the network the following parameters must be set to false( setup.ilm.enabled, ilm.enabled) , but it does not work. And in other threads its resolution is not very clear, thank you

I see this as well, so I've filed a bug for this issue: https://github.com/elastic/beats/issues/16336

It seems like only a bug in the setup command, though -- when I just run filebeat -e instead of filebeat setup -e it gives no errors. If you've had any similar problems with a live Filebeat though please let us know as that would be a much more urgent bug :slight_smile:

Thanks very useful. Is that the """problem"". I solve the problem simply with service filebeat onestart. The problem is filebeat setup -e with this configuration (filebeat logstash)

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.