How to turn off index management in filebeat.yml

Using version 7.2.2. Getting error message:

ERROR instance/beat.go:877 Exiting: Index management requested but the Elasticsearch output is not configured/enabled

But not able to disable index management using setup.ilm.enabled: false or ilm.enabled: false:

#output.elasticsearch:
  # Array of hosts to connect to.
#  hosts: ["parisx:9200"]

  # Optional protocol and basic auth credentials.
  #protocol: "https"
  #username: "elastic"
  #password: "changeme"

 setup.ilm.enabled: false 
 ilm.enabled: false 

output.logstash:
hosts: ["parisx:5044"]

Hello @werowe

I think you just have to comment the ilm configuration lines.

I hope this help. :slight_smile:

The problem is there are none. So I put in these two to turn off what must be the default behavior.

MMmm I have a filebeat 7.2.0 and runs with output kafka without any issue or parameter, from where have you downloaded 7.2.2? 7.2.0 was the latest officialy released https://www.elastic.co/downloads/beats/filebeat

are you sure there is no ilm parameter somewhere?

7.2.0

filebeat-7.2.0-amd64.deb

sudo grep ilm /etc/filebeat/filebeat.yml

setup.ilm.enabled: false

ilm.enabled: false

I didn't change anything and now its working. Must have been some config cached from some previous version? Never will know.

From what version have you upgraded?

Did you follow the steps from https://www.elastic.co/guide/en/beats/libbeat/7.2/upgrading.html ?

There is a note in the documentation about not upgrade from 6.x to 7.x without upgrade before to 6.7

. If you’re on Beats 6.0 through 6.6, upgrade the Elastic Stack and Beats to version 6.7 before proceeding with the 7.0 upgrade.
source: https://www.elastic.co/guide/en/beats/libbeat/7.2/upgrading-6-to-7.html

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.