Error index management Metricbeat to Logstash

I have configured metricbeat and feeding the logs to lagstash. But when im trying to use command : metricbeat setup the following error is coming:

Exiting: Index management requested but the Elasticsearch output is not configured/enabled.

Need your help on how can this be resolved.

What does your Metricbeat config look like?

Just in case , I have already tried ilm.enabled: false. Didn't worked.

The setup command requires Metricbeat to have direct access to Elasticsearch.

Thanks Christian for the information.
I follow up question regarding this - If i feed the data from the beats to the elasticsearch will that create any kind of load on the it and is it safe to implement on any enterprise architecture..?? Need your comments on this.

Thanks.

Metricbeat just need direct access during the setup. Once this has completed you should be able to connect and send data through Logstash if you do desire. A lot of users bypass Logstash and have Beats send directly to Elasticsearch but I do not know if that meets your requirements or not.