Index Management

Hi There

I keep getting this error when i try to start metricbeat. I have got the newest version of Logstash Elasticsearch and Kibana running on centos 7

ERROR instance/beat.go:951 Exiting: Index management requested but the Elasticsearch output is not configured/enabled
Exiting: Index management requested but the Elasticsearch output is not configured/enabled

I already added: setup.ilm.enabled: false

but I am still getting this error

I know this is because i try to run it through logstash. Because if I configure output to be elasticsearch. Than it works.

Thanks in advance

Hi!

What version of Metricbeat are you running? Also did you upgrade from an older version?

Related to How to turn off index management in filebeat.yml

Hi,

I did not upgrade. And the version of metricbeat is 7.9.0-1.

I Already read that thread and tried the settings out. But it did not help

Can you share your complete configuration?

C.

Do you mean configuration files? Of each separate ELK-unit?

Just those of Metricbeat.

 ###################### Metricbeat Configuration Example #######################

# This file is an example configuration file highlighting only the most common
# options. The metricbeat.reference.yml file from the same directory contains all the
# supported options with more comments. You can use it as a reference.
#
# You can find the full configuration reference here:
# https://www.elastic.co/guide/en/beats/metricbeat/index.html

# =========================== Modules configuration ============================

metricbeat.config.modules:
  # Glob pattern for configuration loading
  path: ${path.config}/modules.d/*.yml

  # Set to true to enable config reloading
  reload.enabled: true

  # Period on which files under path should be checked for changes
  reload.period: 10s

# ======================= Elasticsearch template setting =======================

#setup.template.settings:
#  index.number_of_shards: 1
#  index.codec: best_compression
#_source.enabled: false


# ================================== General ===================================

# The name of the shipper that publishes the network data. It can be used to group
# all the transactions sent by a single shipper in the web interface.
#name:

# The tags of the shipper are included in their own field with each
# transaction published.
#tags: ["service-X", "web-tier"]

# Optional fields that you can specify to add additional information to the
# output.
#fields:
#  env: staging

# ================================= Dashboards =================================
# These settings control loading the sample dashboards to the Kibana index. Loading
# the dashboards is disabled by default and can be enabled either by setting the
# options here or by using the `setup` command.
setup.dashboards.enabled: enabled

# The URL from where to download the dashboards archive. By default this URL
# has a value which is computed based on the Beat name and version. For released
# versions, this URL points to the dashboard archive on the artifacts.elastic.co
# website.
#setup.dashboards.url:

# =================================== Kibana ===================================

# Starting with Beats version 6.0.0, the dashboards are loaded via the Kibana API.
# This requires a Kibana endpoint configuration.
setup.kibana:

  # Kibana Host
  # Scheme and port can be left out and will be set to the default (http and 5601)
  # In case you specify and additional path, the scheme is required: http://localhost:5601/path
  # IPv6 addresses should always be defined as: https://[2001:db8::1]:5601
  host: "rhce-server3.pierre.nl:5601"

  # Kibana Space ID
  # ID of the Kibana Space into which the dashboards should be loaded. By default,
  # the Default Space will be used.
  #space.id:

# =============================== Elastic Cloud ================================

# These settings simplify using Metricbeat with the Elastic Cloud (https://cloud.elastic.co/).

# The cloud.id setting overwrites the `output.elasticsearch.hosts` and
# `setup.kibana.host` options.
# You can find the `cloud.id` in the Elastic Cloud web UI.
#cloud.id:

# The cloud.auth setting overwrites the `output.elasticsearch.username` and
# `output.elasticsearch.password` settings. The format is `<user>:<pass>`.
#cloud.auth:

# ================================== Outputs ===================================

# Configure what output to use when sending the data collected by the beat.

# ---------------------------- Elasticsearch Output ----------------------------
#output.elasticsearch.hosts: ["rhce-server2.pierre.nl:9200"]

# Protocol - either `http` (default) or `https`.
#protocol: "https"

  # Authentication credentials - either API key or username/password.
  #api_key: "id:api_key"
  #username: "elastic"
  #password: "changeme"

# ------------------------------ Logstash Output -------------------------------
output.logstash:
  hosts: ["192.168.207.11:5044"]
  index: metricbeat

  # Optional SSL. By default is off.
  # List of root certificates for HTTPS server verifications
  #ssl.certificate_authorities: ["/etc/pki/root/ca.pem"]

  # Certificate for SSL client authentication
  #ssl.certificate: "/etc/pki/client/cert.pem"

  # Client Certificate Key
  #ssl.key: "/etc/pki/client/cert.key"

# ================================= Processors =================================

# Configure processors to enhance or manipulate events generated by the beat.

processors:
  - add_host_metadata: ~
  - add_cloud_metadata: ~
  - add_docker_metadata: ~
  - add_kubernetes_metadata: ~


# ================================== Logging ===================================

# Sets log level. The default log level is info.
# Available log levels are: error, warning, info, debug
#logging.level: debug

# At debug level, you can selectively enable logging only for some components.
# To enable all selectors use ["*"]. Examples of other selectors are "beat",
# "publish", "service".

# ============================= X-Pack Monitoring ==============================
# Metricbeat can export internal metrics to a central Elasticsearch monitoring
# cluster.  This requires xpack monitoring to be enabled in Elasticsearch.  The
# reporting is disabled by default.

# Set to true to enable the monitoring reporter.
#monitoring.enabled: false

# Sets the UUID of the Elasticsearch cluster under which monitoring data for this
# Metricbeat instance will appear in the Stack Monitoring UI. If output.elasticsearch
# is enabled, the UUID is derived from the Elasticsearch cluster referenced by output.elasticsearch.
#monitoring.cluster_uuid:

# Uncomment to send the metrics to Elasticsearch. Most settings from the
# Elasticsearch output are accepted here as well.
# Note that the settings should point to your Elasticsearch *monitoring* cluster.
# Any setting that is not set is automatically inherited from the Elasticsearch
# output configuration, so if you have the Elasticsearch output configured such
# that it is pointing to your Elasticsearch monitoring cluster, you can simply
# uncomment the following line.
#monitoring.elasticsearch:

# ============================== Instrumentation ===============================

# Instrumentation support for the metricbeat.
#instrumentation:
    # Set to true to enable instrumentation of metricbeat.
    #enabled: false

    # Environment in which metricbeat is running on (eg: staging, production, etc.)
    #environment: ""

    # APM Server hosts to report instrumentation results to.
    #hosts:
    #  - http://localhost:8200

    # API Key for the APM Server(s).
    # If api_key is set then secret_token will be ignored.
    #api_key:

    # Secret token for the APM Server(s).
    #secret_token:


# ================================= Migration ==================================

# This allows to enable 6.7 migration aliases
#migration.6_to_7.enabled:

# Enable ILM support. Valid values are true, false, and auto. When set to auto
# # (the default), the Beat uses index lifecycle management when it connects to a
# # cluster that supports ILM; otherwise, it creates daily indices.
setup.ilm.enabled: auto
#
# Set the prefix used in the index lifecycle write alias name. The default alias
# # name is 'metricbeat-%{[agent.version]}'.
setup.ilm.rollover_alias: 'metricbeat'
#
# # Set the rollover index pattern. The default is "%{now/d}-000001".
setup.ilm.pattern: "{now/d}-000001"
#
# # Set the lifecycle policy name. The default policy name is
# # 'beatname'.
setup.ilm.policy_name: "mypolicy"
#
# # The path to a JSON file that contains a lifecycle policy configuration. Used
# # to load your own lifecycle policy.
# # The path to a JSON file that contains a lifecycle policy configuration. Used
# # to load your own lifecycle policy.
setup.ilm.policy_file:
#
# # Disable the check for an existing lifecycle policy. The default is true. If
# # you disable this check, set setup.ilm.overwrite: true so the lifecycle policy
# # can be installed.
setup.ilm.check_exists: true
#
# # Overwrite the lifecycle policy at startup. The default is false.
setup.ilm.overwrite: false

#setup.template.enabled: false
#setup.template.name: "metricbeat"
#setup.template.pattern: "metricbeat-*"
#ilm.enabled: false 
                                                                                                                              1,1           Top

I see that ilm is on auto now, but I also tried with False

Thank you for sharing your configuration.

I would suggest to completely remove everything that is related to ilm (setup.ilm.*) and check again.