Metricbeat index don't increment

Hi all,

I've configured by metricbeat with ilm.enabled: true but i've got only a single index created.
The default should be "{now/d}-000001" but only an index was created.
The problem with this is that the policy freeze my index and metricbeat can't write to a frozen index.

For now i unfreeze the index but what's wrong with my configuration?

I'm using metricbeat 6.7.1

Cheers

Hi @bigster ! :slightly_smiling_face:

Can you share your configuration file, please? I also guess that you have followed the guide here https://www.elastic.co/guide/en/beats/metricbeat/6.7/ilm.html

I guess that you are also using Elasticsearch 6.7

Thanks!

Hi,

I don't know if you want all the file but basically the thing important to this issue is the config below:

#-------------------------- Elasticsearch output ------------------------------
output.elasticsearch:
  # Array of hosts to connect to.
  hosts: ["elasticp01:9200", "elasticp02:9200"]

  # Enabled ilm (beta) to use index lifecycle management instead daily indices.
  ilm.enabled: true

  # Optional protocol and basic auth credentials.
  #protocol: "https"
  #username: "elastic"
  #password: "changeme"

Yes i follow the explanations, but maybe i get a different interpretation about the setup.
Yes i use Elasticsearch 6.7.1.

Cheers,