ERROR: Installation aborted, verification failed for --version


(Sjaak) #1

Hi,

As per the subject line, how do you install a older version of a plugin? In my case I tried "--version 3.5.1", "--version v3.5.1" and some other variations but they all fail.

/usr/share/logstash# bin/logstash-plugin install logstash-codec-netflow --version v3.5.1
Validating logstash-codec-netflow
Validating --version
Plugin --version does not exist
ERROR: Installation aborted, verification failed for --version


(Magnus Bäck) #2

Try putting the --version argument before the plugin name.


(Sjaak) #3

I'm afraid that doesn't work either.

usr/share/logstash# bin/logstash-plugin install --version logstash-codec-netflow v3.5.1
Validating v3.5.1-logstash-codec-netflow
Gem::Requirement::BadRequirementError: Illformed requirement ["logstash-codec-netflow"]
parse at /usr/share/logstash/vendor/jruby/lib/ruby/shared/rubygems/requirement.rb:100
initialize at /usr/share/logstash/vendor/jruby/lib/ruby/shared/rubygems/requirement.rb:130
map! at org/jruby/RubyArray.java:2446
initialize at /usr/share/logstash/vendor/jruby/lib/ruby/shared/rubygems/requirement.rb:130
create at /usr/share/logstash/vendor/jruby/lib/ruby/shared/rubygems/requirement.rb:63
initialize at /usr/share/logstash/vendor/jruby/lib/ruby/shared/rubygems/dependency.rb:58
logstash_plugin? at /usr/share/logstash/lib/pluginmanager/util.rb:26
validate_plugin at /usr/share/logstash/lib/pluginmanager/install.rb:89
verify_remote! at /usr/share/logstash/lib/pluginmanager/install.rb:83
each at org/jruby/RubyArray.java:1613
verify_remote! at /usr/share/logstash/lib/pluginmanager/install.rb:81
execute at /usr/share/logstash/lib/pluginmanager/install.rb:58
run at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/clamp-0.6.5/lib/clamp/command.rb:67
execute at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/clamp-0.6.5/lib/clamp/subcommand/execution.rb:11
run at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/clamp-0.6.5/lib/clamp/command.rb:67
run at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/clamp-0.6.5/lib/clamp/command.rb:132
(root) at /usr/share/logstash/lib/pluginmanager/main.rb:48


(Magnus Bäck) #4

The version number should of course always go after --version, i.e. bin/logstash-plugin install --version v3.5.1 logstash-codec-netflow.


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.