Error -> MapperParsingException-No handler for type [attachment] declared on field

Im new in elasticsearch,i installed elasticsearch version -
elasticsearch-1.4.2 and mapper-attachment-plugin -2.4.1 .
Im refering this site
https://github.com/elasticsearch/elasticsearch-mapper-attachments but there
is error like 'MapperParsingException-No handler for type [attachment]
declared on field' after executing this command:
1) curl -XPUT http://localhost:9200/test
output:
{"acknowledged":true}
2)curl -XPUT
http://localhost:9200/test/person/_mapping -d '
{ "person": { "properties": { "file":
{ "type": "attachment", "path": "full", "fields":
{ "file": { "type": "string",
"term_vector":"with_positions_offsets", "store": true
} } } } }}'

I also check the log elasticsearch.log it correctly load plugins:
[2015-01-06 17:56:25,088][INFO ][node ] [Tag]
version[1.4.2], pid[25034], build[927caff/2014-12-16T14:11:12Z]
[2015-01-06 17:56:25,088][INFO ][node ] [Tag]
initializing ...
[2015-01-06 17:56:25,129][INFO ][plugins ] [Tag] loaded
[mapper-attachments], sites []

[2015-01-06 17:56:27,420][INFO ][node ] [Tag]
initialized
[2015-01-06 17:56:27,420][INFO ][node ] [Tag] starting
...
[2015-01-06 17:56:27,459][INFO ][transport ] [Tag]
bound_address {inet[/0:0:0:0:0:0:0:0:9301]}, publish_address
{inet[/192.168.122.24:9301]}
[2015-01-06 17:56:27,469][INFO ][discovery ] [Tag]
elasticsearch/F1yU83WVSWSZmU6mCDTTIA
[2015-01-06 17:56:30,604][INFO ][cluster.service ] [Tag]
detected_master
[Ion][tqGbZNSDQAa3DgWHo16CVw][isanalab][inet[/192.168.122.24:9300]], added
{[Ion][tqGbZNSDQAa3DgWHo16CVw][isanalab][inet[/192.168.122.24:9300]],},
reason: zen-disco-receive(from master
[[Ion][tqGbZNSDQAa3DgWHo16CVw][isanalab][inet[/192.168.122.24:9300]]])
[2015-01-06 17:56:30,685][INFO ][http ] [Tag]
bound_address {inet[/0:0:0:0:0:0:0:0:9201]}, publish_address
{inet[/192.168.122.24:9201]}
[2015-01-06 17:56:30,685][INFO ][node ] [Tag] started

thank you.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/e8c1033c-c4ef-4a50-a884-1c1e1c7870fa%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

did you restart elasticsearch?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfr https://twitter.com/elasticsearchfr | @scrutmydocs https://twitter.com/scrutmydocs

Le 6 janv. 2015 à 14:15, Shashi shashikant.bagal@isanasystems.com a écrit :

Im new in elasticsearch,i installed elasticsearch version - elasticsearch-1.4.2 and mapper-attachment-plugin -2.4.1 .
Im refering this site https://github.com/elasticsearch/elasticsearch-mapper-attachments but there is error like 'MapperParsingException-No handler for type [attachment] declared on field' after executing this command:
1) curl -XPUT http://localhost:9200/test
output:
{"acknowledged":true}
2)curl -XPUT http://localhost:9200/test/person/_mapping -d '
{ "person": { "properties": { "file": { "type": "attachment", "path": "full", "fields": { "file": { "type": "string", "term_vector":"with_positions_offsets", "store": true } } } } }}'

I also check the log elasticsearch.log it correctly load plugins:
[2015-01-06 17:56:25,088][INFO ][node ] [Tag] version[1.4.2], pid[25034], build[927caff/2014-12-16T14:11:12Z]
[2015-01-06 17:56:25,088][INFO ][node ] [Tag] initializing ...
[2015-01-06 17:56:25,129][INFO ][plugins ] [Tag] loaded [mapper-attachments], sites []
[2015-01-06 17:56:27,420][INFO ][node ] [Tag] initialized
[2015-01-06 17:56:27,420][INFO ][node ] [Tag] starting ...
[2015-01-06 17:56:27,459][INFO ][transport ] [Tag] bound_address {inet[/0:0:0:0:0:0:0:0:9301]}, publish_address {inet[/192.168.122.24:9301]}
[2015-01-06 17:56:27,469][INFO ][discovery ] [Tag] elasticsearch/F1yU83WVSWSZmU6mCDTTIA
[2015-01-06 17:56:30,604][INFO ][cluster.service ] [Tag] detected_master [Ion][tqGbZNSDQAa3DgWHo16CVw][isanalab][inet[/192.168.122.24:9300]], added {[Ion][tqGbZNSDQAa3DgWHo16CVw][isanalab][inet[/192.168.122.24:9300]],}, reason: zen-disco-receive(from master [[Ion][tqGbZNSDQAa3DgWHo16CVw][isanalab][inet[/192.168.122.24:9300]]])
[2015-01-06 17:56:30,685][INFO ][http ] [Tag] bound_address {inet[/0:0:0:0:0:0:0:0:9201]}, publish_address {inet[/192.168.122.24:9201]}
[2015-01-06 17:56:30,685][INFO ][node ] [Tag] started

thank you.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com mailto:elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/e8c1033c-c4ef-4a50-a884-1c1e1c7870fa%40googlegroups.com https://groups.google.com/d/msgid/elasticsearch/e8c1033c-c4ef-4a50-a884-1c1e1c7870fa%40googlegroups.com?utm_medium=email&utm_source=footer.
For more options, visit https://groups.google.com/d/optout https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/76E61E5D-4C90-4E18-B33D-7739A2EFD931%40pilato.fr.
For more options, visit https://groups.google.com/d/optout.

On Tuesday, January 6, 2015 7:15:55 PM UTC+5:30, David Pilato wrote:

did you restart elasticsearch?

--
David Pilato | Technical Advocate | Elasticsearch.com
http://Elasticsearch.com

@dadoonet https://twitter.com/dadoonet | @elasticsearchfr
https://twitter.com/elasticsearchfr | @scrutmydocs
https://twitter.com/scrutmydocs

Reply:

thank you for your reply.
I did restart the elasticsearch service.But still no success.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/63196764-2864-4214-84bd-146994b0c006%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Do you have only one node? Are you using REST or Java client?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 7 janv. 2015 à 08:18, Shashi shashikant.bagal@isanasystems.com a écrit :

On Tuesday, January 6, 2015 7:15:55 PM UTC+5:30, David Pilato wrote:
did you restart elasticsearch?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs

Reply:

thank you for your reply.
I did restart the elasticsearch service.But still no success.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/63196764-2864-4214-84bd-146994b0c006%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/89D3248A-49E7-418B-AA24-86994CF80B02%40pilato.fr.
For more options, visit https://groups.google.com/d/optout.

I have only one node....I didnot get about REST or Java client,will you
please explain about REST or Java client..
On Wednesday, January 7, 2015 12:59:44 PM UTC+5:30, David Pilato wrote:

Do you have only one node? Are you using REST or Java client?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 7 janv. 2015 à 08:18, Shashi <shashika...@isanasystems.com
<javascript:>> a écrit :

On Tuesday, January 6, 2015 7:15:55 PM UTC+5:30, David Pilato wrote:

did you restart elasticsearch?

--
David Pilato | Technical Advocate | Elasticsearch.com
http://Elasticsearch.com

@dadoonet https://twitter.com/dadoonet | @elasticsearchfr
https://twitter.com/elasticsearchfr | @scrutmydocs
https://twitter.com/scrutmydocs

Reply:

thank you for your reply.
I did restart the elasticsearch service.But still no success.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/63196764-2864-4214-84bd-146994b0c006%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/63196764-2864-4214-84bd-146994b0c006%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/090620f9-0b6c-41cf-955f-3e0ba7537cb9%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

How exactly are you creating your mapping?
Which command did you send?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 7 janv. 2015 à 08:55, Shashi shashikant.bagal@isanasystems.com a écrit :

I have only one node....I didnot get about REST or Java client,will you please explain about REST or Java client..

On Wednesday, January 7, 2015 12:59:44 PM UTC+5:30, David Pilato wrote:
Do you have only one node? Are you using REST or Java client?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 7 janv. 2015 à 08:18, Shashi shashika...@isanasystems.com a écrit :

On Tuesday, January 6, 2015 7:15:55 PM UTC+5:30, David Pilato wrote:
did you restart elasticsearch?

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr | @scrutmydocs
Reply:

thank you for your reply.
I did restart the elasticsearch service.But still no success.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/63196764-2864-4214-84bd-146994b0c006%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/090620f9-0b6c-41cf-955f-3e0ba7537cb9%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/03756C83-469A-42C7-BEE0-E3F420FFF489%40pilato.fr.
For more options, visit https://groups.google.com/d/optout.

1: curl -XPUT http://localhost:9200/test

                        output:
                         {"acknowledged":true} 
2:curl -XPUT http://localhost:9200/test/person/_mapping 

http://www.google.com/url?q=http%3A%2F%2Flocalhost%3A9200%2Ftest%2Fperson%2F_mapping&sa=D&sntz=1&usg=AFQjCNHqXUOjd8oZ0fHnWz3Ihk80m-fH2A
-d '
{ "person": { "properties": { "file":
{ "type": "attachment", "path": "full", "fields":
{ "file": { "type": "string",
"term_vector":"with_positions_
offsets", "store": true } } } } }}'

                      output:
                      MapperParsingException-No handler for type 

[attachment] declared on field

-I went through this steps ,please also tell me about any further required
steps before the above two steps...

On Wednesday, January 7, 2015 1:32:02 PM UTC+5:30, David Pilato wrote:

How exactly are you creating your mapping?
Which command did you send?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 7 janv. 2015 à 08:55, Shashi <shashika...@isanasystems.com
<javascript:>> a écrit :

I have only one node....I didnot get about REST or Java client,will you
please explain about REST or Java client..
On Wednesday, January 7, 2015 12:59:44 PM UTC+5:30, David Pilato wrote:

Do you have only one node? Are you using REST or Java client?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 7 janv. 2015 à 08:18, Shashi shashika...@isanasystems.com a écrit :

On Tuesday, January 6, 2015 7:15:55 PM UTC+5:30, David Pilato wrote:

did you restart elasticsearch?

--
David Pilato | Technical Advocate | Elasticsearch.com
http://Elasticsearch.com

@dadoonet https://twitter.com/dadoonet | @elasticsearchfr
https://twitter.com/elasticsearchfr | @scrutmydocs
https://twitter.com/scrutmydocs

Reply:

thank you for your reply.
I did restart the elasticsearch service.But still no success.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/63196764-2864-4214-84bd-146994b0c006%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/63196764-2864-4214-84bd-146994b0c006%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/090620f9-0b6c-41cf-955f-3e0ba7537cb9%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/090620f9-0b6c-41cf-955f-3e0ba7537cb9%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/8d1e3e90-e69c-4b68-b9fe-5b62603460e6%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

1: curl -XPUT http://localhost:9200/test

                        output:
                         {"acknowledged":true} 
2:curl -XPUT http://localhost:9200/test/person/_mapping 

http://www.google.com/url?q=http%3A%2F%2Flocalhost%3A9200%2Ftest%2Fperson%2F_mapping&sa=D&sntz=1&usg=AFQjCNHqXUOjd8oZ0fHnWz3Ihk80m-fH2A
-d '

                  {  "person": {    "properties": {      "file": 

{ "type": "attachment", "path": "full", "fields":
{ "file": { "type": "string",
"term_vector":"with_positions_
offsets", "store": true } } } } }}'

                      output:

                      MapperParsingException-No handler for type 

[attachment] declared on field

-I went through this steps ,please also tell me about any further required
steps before the above two steps...

On Tuesday, January 6, 2015 6:45:30 PM UTC+5:30, Shashi wrote:

Im new in elasticsearch,i installed elasticsearch version -
elasticsearch-1.4.2 and mapper-attachment-plugin -2.4.1 .
Im refering this site
https://github.com/elasticsearch/elasticsearch-mapper-attachments but
there is error like 'MapperParsingException-No handler for type
[attachment] declared on field' after executing this command:
1) curl -XPUT http://localhost:9200/test
output:
{"acknowledged":true}
2)curl -XPUT
http://localhost:9200/test/person/_mapping -d '
{ "person": { "properties": { "file":
{ "type": "attachment", "path": "full", "fields":
{ "file": { "type": "string",
"term_vector":"with_positions_offsets", "store": true
} } } } }}'

I also check the log elasticsearch.log it correctly load plugins:
[2015-01-06 17:56:25,088][INFO ][node ] [Tag]
version[1.4.2], pid[25034], build[927caff/2014-12-16T14:11:12Z]
[2015-01-06 17:56:25,088][INFO ][node ] [Tag]
initializing ...
[2015-01-06 17:56:25,129][INFO ][plugins ] [Tag] loaded
[mapper-attachments], sites []

[2015-01-06 17:56:27,420][INFO ][node ] [Tag]
initialized
[2015-01-06 17:56:27,420][INFO ][node ] [Tag] starting
...
[2015-01-06 17:56:27,459][INFO ][transport ] [Tag]
bound_address {inet[/0:0:0:0:0:0:0:0:9301]}, publish_address {inet[/
192.168.122.24:9301]}
[2015-01-06 17:56:27,469][INFO ][discovery ] [Tag]
elasticsearch/F1yU83WVSWSZmU6mCDTTIA
[2015-01-06 17:56:30,604][INFO ][cluster.service ] [Tag]
detected_master
[Ion][tqGbZNSDQAa3DgWHo16CVw][isanalab][inet[/192.168.122.24:9300]], added
{[Ion][tqGbZNSDQAa3DgWHo16CVw][isanalab][inet[/192.168.122.24:9300]],},
reason: zen-disco-receive(from master
[[Ion][tqGbZNSDQAa3DgWHo16CVw][isanalab][inet[/192.168.122.24:9300]]])
[2015-01-06 17:56:30,685][INFO ][http ] [Tag]
bound_address {inet[/0:0:0:0:0:0:0:0:9201]}, publish_address {inet[/
192.168.122.24:9201]}
[2015-01-06 17:56:30,685][INFO ][node ] [Tag] started

thank you.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/069be0ec-7f76-4cc1-9fe3-537aece683d2%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

1: curl -XPUT http://localhost:9200/test

                        output:
                         {"acknowledged":true} 
2:curl -XPUT http://localhost:9200/test/person/_mapping 

http://www.google.com/url?q=http%3A%2F%2Flocalhost%3A9200%2Ftest%2Fperson%2F_mapping&sa=D&sntz=1&usg=AFQjCNHqXUOjd8oZ0fHnWz3Ihk80m-fH2A
-d '

                  {  "person": {    "properties": {      "file": 

{ "type": "attachment", "path": "full", "fields":
{ "file": { "type": "string",
"term_vector":"with_positions_
offsets", "store": true } } } } }}'

                      output:

                      MapperParsingException-No handler for type 

[attachment] declared on field

-I went through this steps ,please also tell me about any further required
steps before the above two steps...

On Wednesday, January 7, 2015 1:32:02 PM UTC+5:30, David Pilato wrote:

How exactly are you creating your mapping?
Which command did you send?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 7 janv. 2015 à 08:55, Shashi <shashika...@isanasystems.com
<javascript:>> a écrit :

I have only one node....I didnot get about REST or Java client,will you
please explain about REST or Java client..
On Wednesday, January 7, 2015 12:59:44 PM UTC+5:30, David Pilato wrote:

Do you have only one node? Are you using REST or Java client?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 7 janv. 2015 à 08:18, Shashi shashika...@isanasystems.com a écrit :

On Tuesday, January 6, 2015 7:15:55 PM UTC+5:30, David Pilato wrote:

did you restart elasticsearch?

--
David Pilato | Technical Advocate | Elasticsearch.com
http://Elasticsearch.com

@dadoonet https://twitter.com/dadoonet | @elasticsearchfr
https://twitter.com/elasticsearchfr | @scrutmydocs
https://twitter.com/scrutmydocs

Reply:

thank you for your reply.
I did restart the elasticsearch service.But still no success.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/63196764-2864-4214-84bd-146994b0c006%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/63196764-2864-4214-84bd-146994b0c006%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/090620f9-0b6c-41cf-955f-3e0ba7537cb9%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/090620f9-0b6c-41cf-955f-3e0ba7537cb9%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/2dfe0649-28ab-4989-a8ab-ca493ca2d176%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Hi Shashi,

I just tried to reproduce your issue.

I:

  • downloaded elasticsearch 1.4.2
  • ran bin/plugin -install elasticsearch/elasticsearch-mapper-attachments/2.4.1
  • ran bin/elasticsearch

Then:

curl -XPUT http://localhost:9200/test http://localhost:9200/test
curl -XPUT http://localhost:9200/test/person/_mapping -d '{
"person": {
"properties": {
"file": {
"type": "attachment",
"path": "full",
"fields": {
"file": {
"type": "string",
"term_vector":"with_positions_offsets",
"store": true
}
}
}
}
}
}’

Which gave: {"acknowledged":true}

And in logs:

[2015-01-09 15:33:31,793][INFO ][cluster.metadata ] [Inza] [test] create_mapping [person]

curl -XGET "http://localhost:9200/test/person/_mapping?pretty" gave:

{
"test" : {
"mappings" : {
"person" : {
"properties" : {
"file" : {
"type" : "attachment",
"path" : "full",
"fields" : {
"file" : {
"type" : "string",
"store" : true,
"term_vector" : "with_positions_offsets"
},
"author" : {
"type" : "string"
},
"title" : {
"type" : "string"
},
"name" : {
"type" : "string"
},
"date" : {
"type" : "date",
"format" : "dateOptionalTime"
},
"keywords" : {
"type" : "string"
},
"content_type" : {
"type" : "string"
},
"content_length" : {
"type" : "integer"
},
"language" : {
"type" : "string"
}
}
}
}
}
}
}
}

Everything is fine. I don’t know what you are doing.

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfr https://twitter.com/elasticsearchfr | @scrutmydocs https://twitter.com/scrutmydocs

Le 8 janv. 2015 à 06:51, Shashi shashikant.bagal@isanasystems.com a écrit :

1: curl -XPUT http://localhost:9200/test http://localhost:9200/test

                        output:
                         {"acknowledged":true} 
2:curl -XPUT http://localhost:9200/test/person/_mapping <http://www.google.com/url?q=http%3A%2F%2Flocalhost%3A9200%2Ftest%2Fperson%2F_mapping&sa=D&sntz=1&usg=AFQjCNHqXUOjd8oZ0fHnWz3Ihk80m-fH2A> -d '

                  {  "person": {    "properties": {      "file": {        "type": "attachment",        "path": "full",        "fields": {          "file": {            "type": "string",                     "term_vector":"with_positions_

offsets", "store": true } } } } }}'

                      output:

                      MapperParsingException-No handler for type [attachment] declared on field

-I went through this steps ,please also tell me about any further required steps before the above two steps...

On Wednesday, January 7, 2015 1:32:02 PM UTC+5:30, David Pilato wrote:
How exactly are you creating your mapping?
Which command did you send?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 7 janv. 2015 à 08:55, Shashi <shashika...@isanasystems.com <javascript:>> a écrit :

I have only one node....I didnot get about REST or Java client,will you please explain about REST or Java client..
On Wednesday, January 7, 2015 12:59:44 PM UTC+5:30, David Pilato wrote:
Do you have only one node? Are you using REST or Java client?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 7 janv. 2015 à 08:18, Shashi <shashika...@isanasystems.com <>> a écrit :

On Tuesday, January 6, 2015 7:15:55 PM UTC+5:30, David Pilato wrote:
did you restart elasticsearch?

--
David Pilato | Technical Advocate | Elasticsearch.com http://elasticsearch.com/
@dadoonet https://twitter.com/dadoonet | @elasticsearchfr https://twitter.com/elasticsearchfr | @scrutmydocs https://twitter.com/scrutmydocs

Reply:

thank you for your reply.
I did restart the elasticsearch service.But still no success.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com <>.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/63196764-2864-4214-84bd-146994b0c006%40googlegroups.com https://groups.google.com/d/msgid/elasticsearch/63196764-2864-4214-84bd-146994b0c006%40googlegroups.com?utm_medium=email&utm_source=footer.
For more options, visit https://groups.google.com/d/optout https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/090620f9-0b6c-41cf-955f-3e0ba7537cb9%40googlegroups.com https://groups.google.com/d/msgid/elasticsearch/090620f9-0b6c-41cf-955f-3e0ba7537cb9%40googlegroups.com?utm_medium=email&utm_source=footer.
For more options, visit https://groups.google.com/d/optout https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com mailto:elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/2dfe0649-28ab-4989-a8ab-ca493ca2d176%40googlegroups.com https://groups.google.com/d/msgid/elasticsearch/2dfe0649-28ab-4989-a8ab-ca493ca2d176%40googlegroups.com?utm_medium=email&utm_source=footer.
For more options, visit https://groups.google.com/d/optout https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/E9C134AB-0C48-4577-96BD-28DF7512BA79%40pilato.fr.
For more options, visit https://groups.google.com/d/optout.

Hi Sashi,

I faced the same issue. When I started elasticsearch from bin using \bin\elasticsearch - then I stopped recieving mapper error. Hope it helps
Thanks,
Tarun