No handler for type [attachment] declared on field [file]


(samaswin) #1

Hi,
I have installed the FSRiver and mapper attachments in my ES.
I have run the following script, But it always showing No handler for type
[attachment] declared on field [file] error.
I try all the solutions from internet. But it's not working for me. Can any
one help me.

The Example:

PUT:
http://localhost:9200/mydocs/
{
"doc": {
"properties": {
"file": {
"type": "attachment",
"path": "full",
"fields": {
"file": {
"type": "string",
"store": "yes",
"term_vector": "with_positions_offsets"
}
}
}
}
}
}

PUT:
http://localhost:9200/_river/mydocs/_meta
{
"type": "fs",
"fs": {
"url": "/home/likewise-open/ashwin_raj/Desktop/Folder",
"update_rate": 900000,
"includes": ".doc,.pdf",
"excludes": "resume"
}
}

Actually my requirement is indexing the folder.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(samaswin) #2

I found a bug, The mapper attachments not installed. Its showing a error,
Installed mapper-attachments into
/usr/share/elasticsearch/plugins/mapper-attachments
Plugin installation assumed to be site plugin, but contains source code,
aborting installation...

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(samaswin) #3

I resolved the problem

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #4