Error setting up Dashboards

I have a 7 node ES cluster based on 3 MN and 4 DN version 7.5, using TLS. The cluster has been working without a problem until this morning when I attempt to install auditbeat on one master node to start testing and getting information.
The problem started when I ran auditbeat setup --dashboards in order to setup the dashboards in Kibana.
When I ran the mentioned command I get:

 auditbeat setup --dashboards
 Loading dashboards (Kibana must be running and reachable
 Exiting: error connecting to Kibana: fail to get the Kibana version: HTTP GET request to fails: fail to execute the HTTP GET request: Get dial tcp serverip:5601: connect: 
 connection refused. Response: . 

I already review some of the responses that are on this platform and my configuration is the same.
Actually when I typed on my browser I don't get a response back, but if I remove the 5601 port I get a response back.

so I logged in into my Kibana server and added a non-loop back address to the local host IP address, now I am able to see the same response if I type on the browser including the port but if I ran the setup command to install the dashboards I still get the same error, no matter on what server I am, I already even try a windows server installing a filebeat and trying to import the filebeat dashboards same error.

Also tried the solution I saw here about adding the following fields to the auditbeat.yml file
ssl.enabled: true
ssl.certificate_authorities: ["/etc/auditbeat/certs/ca.pem"]
ssl.verification_mode: none
and still the same.

Weird thing is that I was able to started auditbeat without an issue and it was able to import the new index and start adding documents to the cluster.

Any ideas? I've been having this issue for 3 days now and nothing, not even ES support has been able to help.

Thank you

Hi @eemtzc - I checked your support case and I see that our support engineer provided an update to you. Could you follow-up with our support team in the support case? If you could send the auditbeat.yml and kibana.yml configuration files in the support case, our support team will review them and provide further guidance. Thank you for your collaboration.

Hello @ropc sorry but I don't see where did the support engineer update the case. If you could point me I will send the files to him.
Thank you

@eemtzc - Let me send you a private message.

Another solution for this same error.

Loading dashboards (Kibana must be running and reachable)
Exiting: error connecting to Kibana: fail to get the Kibana version: HTTP GET request to https://kibana.domain:5601/api/status fails: fail to execute the HTTP GET request: Get dial tcp kibanaip:5601: connect: connection refused. Response: .

  1. Stop the beat you are trying to setup the dashboards for.

  2. Go to kibana server

on the Kibana.yml file

Change the following

* Uncomment

  * #server.ssl.enabled: true

  * #server.ssl.key: /etc/kibana/<kibanasrv>/<kibanasrv>.key

  * #server.ssl.certificate: /etc/kibana/<kibanasrv>/<kibanasrv>.crt

* Restart Kibana Service

* Restart the beat service

On the beat server: test by running :

curl -v h[ttps://kibana.domain:5601/api/status]
      (You should see connection establish, probably will show an error but won't be the same error)
           beatname setup --dashboard 

Dashboards should load

Once dashboards load into kibana, return all the settings to the way they were and restart kibana and beat service.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.