Error trying to run rspec on a custom logstash filter


(Pabloaredu) #1

Hi all,

Does anyone have any experience with running rspec on Logstash filters for Logstash 6*?? I've tried to run bundle exec rspec but keep getting this error:

no such file to load -- org/apache/logging/log4j/log4j-core/2.6.2/log4j-core-2.6.2 (LoadError)

I tried follow the instructions here but wanted to see if there were other things I could try without having to install Maven..

I have also tried to update the gemspec following this so my gemspec looks like this

s.requirements << "jar 'org.apache.logging.log4j:log4j-core', '2.6.2'"
s.add_runtime_dependency ‘jar-dependencies’

And then tried running gem build [filename].gemspec. I tried doing all of the above with the existing logstash-filter-mutate on my local computer just to see if there were configuration errors but none of this works. Any help or insight on how to tackle this would be greatly appreciated!


(Pabloaredu) #2

Just solved it. I had to run lock_jars... Sorry everyone!


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.