Lostash Plugins Failing with some Dependency error


(Mike ) #1

Hello-
I cloned many logstash plugins and executed the specs, but I get the jars dependency issues.

An error occurred while loading ./spec/unit/outputs/elasticsearch_spec.rb.
Failure/Error: require "logstash/devutils/rspec/spec_helper"

RuntimeError:


  	you might need to reinstall the gem which depends on the missing jar or in case there is Jars.lock then resolve the jars with `lock_jars` command

  no such file to load -- com/fasterxml/jackson/module/jackson-module-afterburner/2.7.4/jackson-module-afterburner-2.7.4 (LoadError)

Could someone help me out with this.


(Magnus B├Ąck) #2

More details please. Which JRuby? What's the complete sequence of commands you ran?


(Mike ) #3

Hi @magnusbaeck-
Here are the Version details-

jruby 9.2.0.0 (2.5.0) 2018-05-24 81156a8 Java HotSpot(TM) 64-Bit Server VM 25.11
1-b14 on 1.8.0_111-b14 +jit [mswin32-x86_64]

ruby 2.3.3p222 (2016-11-21 revision 56859) [i386-mingw32]

java version "1.8.0_161"
Java(TM) SE Runtime Environment (build 1.8.0_161-b12)
Java HotSpot(TM) 64-Bit Server VM (build 25.161-b12, mixed mode)

And Logstash had been set as ENV. Variable with Version 6.1.1

I ran bundle install which was successful and created gemlock file; installed rspec it was also fine.
and when I run any of the spec file, I get this dependencies issues. Please let me know if am missing anything. Thank !


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.