Error: unknown command "enroll" for "metricbeat"


(Matt Vasquez) #1

Anyone know if Beats Central Management in 6.5 is supported on Metricbeat 6.5 for Windows??

using:

PS C:\Program Files\metricbeat> metricbeat.exe enroll https://localhost:5601/kibana d20f2f72baab42
c78a1961267424c086
The term 'metricbeat.exe' is not recognized as the name of a cmdlet, function, script file, or operable program. Check
the spelling of the name, or if a path was included, verify that the path is correct and try again.
At line:1 char:15
+ metricbeat.exe <<<<  enroll https://localhost:5601/kibana d20f2f72baab42c78a1961267424c086
    + CategoryInfo          : ObjectNotFound: (metricbeat.exe:String) [], CommandNotFoundException
    + FullyQualifiedErrorId : CommandNotFoundException


Suggestion [3,General]: The command metricbeat.exe was not found, but does exist in the current location. Windows PowerS
hell doesn't load commands from the current location by default. If you trust this command, instead type ".\metricbeat.e
xe". See "get-help about_Command_Precedence" for more details.
PS C:\Program Files\metricbeat> .\metricbeat.exe enroll https://localhost:5601/kibana d20f2f72baab
42c78a1961267424c086
Error: unknown command "enroll" for "metricbeat"
Run 'metricbeat --help' for usage.

(Pier-Hugues Pellerin) #2

@matt We had an issue with the packaging for windows it will fixed in 6.5.1 sorry for the inconvenience. Related PR: https://github.com/elastic/beats/pull/9103


(Larry Gregory) #3

@pierhugues any chance that ARM is also impacted? I'm seeing the same when trying to enroll metricbeat that I built from source on a raspberry pi.

I know that ARM isn't officially supported, but the rest of the build works just fine. I tried building from the 6.5.1 release too, with the same error:

pi@assistant:~/go/src/github.com/elastic/beats/metricbeat $ make
go build -i -ldflags "-X github.com/elastic/beats/libbeat/version.buildTime=2018-11-30T14:03:24Z -X github.com/elastic/beats/libbeat/version.commit=b1c6ac83cc037bd75395334eed23b64bd63c87ef"
pi@assistant:~/go/src/github.com/elastic/beats/metricbeat $ ./metricbeat enroll
Error: unknown command "enroll" for "metricbeat"
Run 'metricbeat --help' for usage.
pi@assistant:~/go/src/github.com/elastic/beats/metricbeat $ ./metricbeat version
metricbeat version 6.5.1 (arm), libbeat 6.5.1 [b1c6ac83cc037bd75395334eed23b64bd63c87ef built 2018-11-30 14:03:24 +0000 UTC]

(Andrew Kroh) #4

@Larry_Gregory enroll is only present in the binary produced from the x-pack/metricbeat directory. If you build from there you will have the command.