I'm trying to install logstash-input-jms plugin but when I run the commando logstash-plugin install --no-verify logstash-input-jms I'm receiving the following message:
Error Bundler::InstallError, retrying 1/10
An error occurred while installing semantic_logger (4.0.0), and Bundler cannot continue.
ERROR: Installation Aborted, message: An error occurred while installing semantic_logger (4.0.0), and Bundler cannot continue.
Make sure that
gem install semantic_logger -v '4.0.0'succeeds before bundling.
So, investigating the problem I've try to execute the command mentioned in the error using gem that inside logstash (vendor/jruby/bin/gem) and I've received the following message when I tried to run the command to install semantic_logger
gem install semantic_logger -v '4.0.0'
Fetching: concurrent-ruby-1.0.5-java.gem (100%)
Successfully installed concurrent-ruby-1.0.5-java
Fetching: semantic_logger-4.0.0.gem (100%)
ERROR: Error installing semantic_logger:
semantic_logger requires Ruby version >= 2.1.
I could see that logstash-5.2.2 uses jruby 1.7.25.
jruby 1.7.25 (1.9.3p551) 2016-04-13 867cb81 on Java HotSpot(TM) 64-Bit Server VM 1.8.0_121-b13 +jit [Windows 10-amd64]
One week ago I could install this plugin without problems but now I can't. I also noticed that a new version of semantic_logger (4.0.0) was released two days ago, probably something changed and that's the reason of the problem but I have no idea of how to solve it.
Maybe a way to workaround this is force to use semantic_logger 3.4.1 instead of new version 4.0.0 but I don't know if is possible to force a specific version of a dependency when installing the plugin.
Does anybody knows how to make it work?