Logstash 5.4 Plugins - Unable to install plugins - Errors with httparty


#1

Logstash - 5.4, Ruby 1.9 (default comes with logstash)

I do see below errors for DEBUG=1 bin/logstash-plugin update.

Due to these errors (httparty), I am unable to install any plugins like email, hipchat etc.

Gem::InstallError: httparty requires Ruby version >= 2.0.0.

Bundler::InstallError: An error occurred while installing httparty (0.15.5), and Bundler cannot continue.
Make sure that `gem install httparty -v '0.15.5'` succeeds before bundling.
  install_gem_from_spec at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/installer.rb:145
   install_sequentially at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/installer.rb:269
                   each at org/jruby/RubyArray.java:1613
                   each at /usr/share/logstash/vendor/jruby/lib/ruby/1.9/forwardable.rb:201
   install_sequentially at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/installer.rb:268
                    run at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/installer.rb:90
                install at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/installer.rb:18
                    run at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/cli/update.rb:51
                 update at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/cli.rb:178
                    run at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/vendor/thor/lib/thor/command.rb:27
         invoke_command at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/vendor/thor/lib/thor/invocation.rb:126
               dispatch at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/vendor/thor/lib/thor.rb:359
                  start at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/vendor/thor/lib/thor/base.rb:440
                  start at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/bundler-1.9.10/lib/bundler/cli.rb:10
        execute_bundler at /usr/share/logstash/lib/bootstrap/bundler.rb:152
                invoke! at /usr/share/logstash/lib/bootstrap/bundler.rb:113
           update_gems! at /usr/share/logstash/lib/pluginmanager/update.rb:67
                execute at /usr/share/logstash/lib/pluginmanager/update.rb:32
                    run at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/clamp-0.6.5/lib/clamp/command.rb:67
                execute at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/clamp-0.6.5/lib/clamp/subcommand/execution.rb:11
                    run at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/clamp-0.6.5/lib/clamp/command.rb:67
                    run at /usr/share/logstash/vendor/bundle/jruby/1.9/gems/clamp-0.6.5/lib/clamp/command.rb:132
                 (root) at /usr/share/logstash/lib/pluginmanager/main.rb:48

(Orhan) #2

well i have 5.4.o installe on centos7 via the rpm packages, and i use the below to install plugins and it works, give it a try:

/usr/share/logstash/bin/logstash-plugin install logstash-filter-translate


#3

Hi Orhiee,

After trying this, still i got same issue.

i am trying to install logstash-output-hipchat

-Regards, dp


(Orhan) #4

i just tried the below and got errors as well

sudo /usr/share/logstash/bin/logstash-plugin install logstash-output-hipchat

Error: it seems to be trying 10 times:
Make sure that `gem install httparty -v 0.15.5 succeeds before bundling.
WARNING: SSLSocket#session= is not supported
Error Bundler::InstallError, retrying 7/10
An error occurred while installing httparty (0.15.5), and Bundler cannot continue.

tryyed to see if "gem" was installed and it wasnt, did a "yum install gem -y" and than " gem install httparty -v '0.15.5'` " and didnt really help :confused:


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.