Error while restarting elastic service when I add true to the .yml file

Hello ppl,

when I add true rule to .yml file and I restart the service using : sudo systemctl restart Elasticsearch.service I got this error:

Job for Elasticsearch.service failed because the control process exited with error code.
See "systemctl status Elasticsearch.service" and "journalctl -xe" for details.

here is my .yml file configurations:

======================== Elasticsearch Configuration =========================

NOTE: Elasticsearch comes with reasonable defaults for most settings.

Before you set out to tweak and tune the configuration, make sure you

understand what are you trying to accomplish and the consequences.

The primary way of configuring a node is via this file. This template lists

the most important settings you may want to configure for a production cluster.

Please consult the documentation for further information on configuration options:

Elasticsearch Guide | Elastic

---------------------------------- Cluster -----------------------------------

Use a descriptive name for your cluster: my-application

------------------------------------ Node ------------------------------------

Use a descriptive name for the node: node-1

Add custom attributes to the node:

#node.attr.rack: r1

----------------------------------- Paths ------------------------------------

Path to directory where to store the data (separate multiple locations by comma): /var/lib/Elasticsearch

Path to log files:

path.logs: /var/log/Elasticsearch

----------------------------------- Memory -----------------------------------

Lock the memory on startup:

#bootstrap.memory_lock: true

Make sure that the heap size is set to about half the memory available

on the system and that the owner of the process is allowed to use this


Elasticsearch performs poorly when the system is swapping the memory.

---------------------------------- Network -----------------------------------

By default Elasticsearch is only accessible on localhost. Set a different

address here to expose this node on the network:

By default Elasticsearch listens for HTTP traffic on the first free port it

finds starting at 9200. Set a specific HTTP port here:

#http.port: 9200

For more information, consult the network module documentation.

--------------------------------- Discovery ----------------------------------

Pass an initial list of hosts to perform discovery when this node is started:

The default list of hosts is ["", "[::1]"]

discovery.seed_hosts: ["host1", ""]

Bootstrap the cluster using an initial set of master-eligible nodes:

#cluster.initial_master_nodes: ["node-1", "node-2"]

For more information, consult the discovery and cluster formation module documentation.

---------------------------------- Various -----------------------------------

Require explicit names when deleting indices:

#action.destructive_requires_name: true

---------------------------------- Security ----------------------------------

*** WARNING ***

Elasticsearch security features are not enabled by default.

These features are free, but require configuration changes to enable them.

This means that users don’t have to provide credentials and can get full access

to the cluster. Network connections are also not encrypted.

To protect your data, we strongly encourage you to enable the Elasticsearch security features.

Refer to the following documentation for instructions.

Configure security for the Elastic Stack | Elasticsearch Guide [7.16] | Elastic

---------------------------------------------- X-pack monitoring --------------------

xpack.monitoring.collection.enabled: true
xpack.monitoring.Elasticsearch.collection.enabled: true true true

please anyone can help me out?

What errors were reported when you did that?

Welcome to our community! :smiley:

Please format your code/logs/config using the </> button, or markdown style back ticks. It helps to make things easy to read which helps us help you :slight_smile:

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.