Error While Running Elasticsearch On Windows 10 ( After Windows Crashed )


(Mansour Ahmadi) #1

After My Windows Crashed My Elasticsearch Wont Start
The Error Is :

Error: Could not find or load main class Active

And The Log Say`s :

[2016-12-22 09:21:19] [error] [ 8036] Commons Daemon procrun failed with exit value: 5 (Failed to start service)
[2016-12-22 09:21:19] [error] [ 8036] The data area passed to a system call is too small.

i try`ed deleting and re downloading elasticsearch but error still remains ...
what can i do ?
reinstall windows and copy the node folder into new elasticsearch ? :cry:


(David Pilato) #2

Did you install it as a service?
Did you remove the service and reinstall it again?

When you say "the log says", do you mean elasticsearch log or windows event log? I guess the later but prefer to ask.


(Mansour Ahmadi) #3

at first i did not used elastic as service after crash and the error i installed the elastic as service and removed it but none of that worked

the service log said that :

unfortunately elastic does n`t make any logs


(David Pilato) #4

Can you just:

And paste anything you see here?


(Mansour Ahmadi) #5

C:\ELDB\1\elasticsearch-5.1.1>bin\elasticsearch
Error: Could not find or load main class Active

C:\ELDB\1\elasticsearch-5.1.1>java -version
java version "1.8.0_25"
Java(TM) SE Runtime Environment (build 1.8.0_25-b18)
Java HotSpot(TM) 64-Bit Server VM (build 25.25-b02, mixed mode)


(David Pilato) #6

I have no idea. Can you try this on another Windows machine?


(Mansour Ahmadi) #7

i guess i shoud reinstall the windows then !

can the node folder restored to the Machine ? :frowning:


(David Pilato) #8

Sorry but didn't you say that you tried with an empty installation as I described here?

Did you try something else?

If not, what would you like to restore as the steps I described are launching an empty node?


(Mansour Ahmadi) #9

yes , the picture is for a new downloaded elasticsearch as you described ...


(David Pilato) #10

Ok. Before reinstalling Windows which looks like to me a bit too much, any chance you can try on another machine?


(Mansour Ahmadi) #11

yes i did ! the elasticsearch work good on other machine !
i installed it on my osx and other windows machine and it works normal ! but on this machine i have error on class Active

and on other machine some of my data is lost
the _count was 59mil but now its 52mil !
this crash waste all my work :(( ( i HATE Windows )


(system) #12

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.