Error while starting elasticsearch v8.9.1

Whenever I start up ES by running ES .bat file on Windows, I receive this error:

[ERROR][o.e.b.Elasticsearch ] [node-1] fatal exception while booting Elasticsearchorg.elasticsearch.ElasticsearchSecurityException: invalid configuration for - [] is not set, but the following settings have been configured in elasticsearch.yml : [,] at org.elasticsearch.xcore@8.9.1/org.elasticsearch.xpack.core.ssl.SSLService.validateServerConfiguration( at org.elasticsearch.xcore@8.9.1/org.elasticsearch.xpack.core.ssl.SSLService.loadSslConfigurations( at org.elasticsearch.xcore@8.9.1/org.elasticsearch.xpack.core.ssl.SSLService.( at org.elasticsearch.xcore@8.9.1/org.elasticsearch.xpack.core.XPackPlugin.createSSLService( at org.elasticsearch.xcore@8.9.1/org.elasticsearch.xpack.core.XPackPlugin.createComponents(

How can I resolve this?

Hi @sanyam,

Can you try setting the option in your configuration?

I tried, but still the same error continues.

Ok, can you share your configuration please?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.