Error with bulk upload & Role permissions

I'm trying to bulk upload using a specific user/role and getting an error I don't understand given my configuration. Other than a .yml security file (which I'm not using) I can't work out how to set the specific permission [indices:data/write/bulk[s]].

Could anybody suggest where I look next please

Im using op_type = 'index' in the bulk upload

The error is

security_exception in 5E8CD8DB00008C4F292405AE-1586288859, uploading to bbg-parse-msg-v3-20200409153639054771 because action [indices:data/write/bulk[s]] is unauthorized for user [bbg-ingest]

The role is:

  "bloomberg-ingest" : {
    "cluster" : [
    "indices" : [
        "names" : [
        "privileges" : [
        "field_security" : {
          "grant" : [
          "except" : [ ]
        "allow_restricted_indices" : false
    "applications" : [ ],
    "run_as" : [ ],
    "metadata" : { },
    "transient_metadata" : {
      "enabled" : true

Huh. just worked out the answer.

I was using an Alias to update the latest index that is not in the same format as the underlying index name

So I was posting to IPS_data_input_bbg_ib which is an alias of bbg-parse-ib-v4-20200409

I've changed the post to be the index itself and now it works

The Alias does not match the mask in Indices (I guess as it is not an Index) however the Alias points at the index!! And the error message is a little oblique.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.