Errors upgrading from es 0.17.7 to 0.18.2


(surielb) #1

Attempting to upgrade our cluster from v 0.17.7 of es to the latest 0.18.2 results in the updated nodes not being able to join the cluster and loop the following warning:

[2011-10-31 16:24:09,723][WARN ][transport.netty ] [James Howlett] Message not fully read (request) for [132808] and action [discovery/zen/multicast], resetting

attempting to load the data into a new cluster fails too.

Ideas? Help? anyone?

Thanks,


(Shay Banon) #2

Is there a chance that a node with a 0.17 node version is joining a node
with 0.18 version? There is no support (yet) for cross major version nodes
cluster.

On Mon, Oct 31, 2011 at 3:45 PM, surielb suriel@conduit.com wrote:

Attempting to upgrade our cluster from v 0.17.7 of es to the latest 0.18.2
results in the updated nodes not being able to join the cluster and loop
the
following warning:

[2011-10-31 16:24:09,723][WARN ][transport.netty ] [James Howlett]
Message not fully read (request) for [132808] and action
[discovery/zen/multicast], resetting

attempting to load the data into a new cluster fails too.

Ideas? Help? anyone?

Thanks,

--
View this message in context:
http://elasticsearch-users.115913.n3.nabble.com/Errors-upgrading-from-es-0-17-7-to-0-18-2-tp3467850p3467850.html
Sent from the ElasticSearch Users mailing list archive at Nabble.com.


(surielb) #3

I gathered there was no support however I could not load the data into a new cluster in any way, was there a change in the file structure?

Also is there any best practice for upgrading a live cluster?

Suriel Bendahan

On Oct 31, 2011, at 19:31, "kimchy [via ElasticSearch Users]" ml-node+s115913n3468416h35@n3.nabble.com wrote:

Is there a chance that a node with a 0.17 node version is joining a node with 0.18 version? There is no support (yet) for cross major version nodes cluster.

On Mon, Oct 31, 2011 at 3:45 PM, surielb <[hidden email]</user/SendEmail.jtp?type=node&node=3468416&i=0>> wrote:
Attempting to upgrade our cluster from v 0.17.7 of es to the latest 0.18.2
results in the updated nodes not being able to join the cluster and loop the
following warning:

[2011-10-31 16:24:09,723][WARN ][transport.netty ] [James Howlett]
Message not fully read (request) for [132808] and action
[discovery/zen/multicast], resetting

attempting to load the data into a new cluster fails too.

Ideas? Help? anyone?

Thanks,

--
View this message in context: http://elasticsearch-users.115913.n3.nabble.com/Errors-upgrading-from-es-0-17-7-to-0-18-2-tp3467850p3467850.html
Sent from the ElasticSearch Users mailing list archive at Nabble.com.


If you reply to this email, your message will be added to the discussion below:
http://elasticsearch-users.115913.n3.nabble.com/Errors-upgrading-from-es-0-17-7-to-0-18-2-tp3467850p3468416.html
To unsubscribe from Errors upgrading from es 0.17.7 to 0.18.2, click herehttp://elasticsearch-users.115913.n3.nabble.com/template/NamlServlet.jtp?macro=unsubscribe_by_code&node=3467850&code=c3VyaWVsQGNvbmR1aXQuY29tfDM0Njc4NTB8LTYxMjg5ODU0OQ==.


(system) #4