Errors when enabling SSL behing nginx proxy


I'm running Kibana on AWS while using Elasticloud for Elasticsearch. I got nginx set up with let's encrypt while running Kibana on localhost.

This is working fine but results in a insecure cookies warning in the logs. According to the documentation this is fixed by enabling SSL. I generated a .key and .crt and configured kibana.yml but now I'm getting 502 Bad gateway errors.


server.port: 5601 "localhost"
#server.basePath: "/kibana"
kibana.defaultAppId: "dashboards"
elasticsearch.username: "user"
elasticsearch.password: "pass" true
elasticsearch.hosts: ["https://elasticcloudip"]
server.ssl.enabled: true
server.ssl.key: /path/server.key
server.ssl.certificate: /path/server.crt
server.ssl.keyPassphrase: somethingsomething


If you're running on a Linux with selinux you could try running this command:

setsebool -P httpd_can_network_connect on

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.