Erros on kibana devtools "parse_exception"


i have this error when i use dev tools, GET is working but PUT and POST action is not working,

do you have any idea ?

thanks for your response

The request looks fine, but it could be the tool has a hard time parsing it. Could you try by spacing it out over a few lines:

POST my-index/_doc
"date_of_birth": "18.05.1985"

yes @majagrubic i tried but same error :frowning:

do you have any idea ?

Here are some of the things I'd suggest to try:

  1. Try with a different index and see if it still fails
  2. Check your index privileges
  3. Try executing a cURL request against your Elasticsearch cluster directly


@majagrubic, i tried:

  1. Try with a different index and see if it still fails

it fails with different index

  1. Check your index privileges

i'me superuser

  1. Try executing a cURL request against your Elasticsearch cluster directly

POST and PUT working with curl directly to the cluster.

GET is working but not PUT and POST on the DevTools,

i don't know why PUT and POST is not working while GET is working.

thanks for any response,

Could you check the request in the network tab of your browser? It will look something like proxy?path=my-index-00001%2F_doc%2F&method=POST

Does it have request payload correctly set?

@majagrubic how to check, which tools did you use ?

This is just Devtools in your browser, in Chrome it's View > Developer Tools and then the Network tab.

yes @majagrubic but i don't see any information

Request payload is what you need, it's right there in the Payload tab.

same error

Sorry if I wasn't clear, I am interested in this bit:

From what I can see, it looks like the request is correctly being sent. Can you expand this section and post it here? Also, can you confirm that you've executed a cURL request from your OS terminal against Elasticsearch cluster and that that executed correctly?

curl -X POST "localhost:9200/my-index-000001/_doc/?pretty" -H 'Content-Type: application/json' -d'
  "@timestamp": "2099-11-15T13:12:00",
  "message": "GET /search HTTP/1.1 200 1070000",
  "user": {
    "id": "kimchy"

Also, what is that security exception?

So the request is correctly being sent, which means the error is a bit misleading, as the request body is in fact in the request. I think this could be:

  1. a privileges issue
  2. Kibana having problems communicating with ES
  3. ES acting out for some reason

We can narrow this down if you execute a cURL request and can confirm that it's working.

as you see curl with PUT is working @majagrubic

This is really weird. Given everything you've posted, I don't think that it's an issue with Kibana DevTools, nor an issue with the Elasticsearch cluster. Could be a permissions issue or some hidden whitespace.

i searched to update kibana and Elasticsearch but that not working.

Hi, I have a few questions:

  1. What version of Kibana are you on?
  2. Is there a reverse proxy in front of Elasticsearch or Kibana?
  3. Have you tried adding a leading slash to the path?


i run kibana 7.15.2 and Elasticsearch 7.15.2, i don't use proxy, what you mean add leading slash ?