ES 2.4 indices.store.throttle settings with SSD servers

Hello,

We're currently joining our new servers to existing cluster.
They're pretty decent with SSD disks behind RAID0 array over controller.

When we start ES we get:

[2016-09-09 11:31:15,004][INFO ][env ] [XXXX] using [1] data paths, mounts [[/var/lib/elasticsearch (/dev/mapper/vg2-LVElas)]], net usable_space [3.3tb], net total_space [3.5tb], spins? [possibly], types [ext4]

We don't use spins, and ES shows possibly, does this can affect performances? How can we tell ES that we're using SSDs rather than spinning disks?

Further in the log there is also throttling info:

[2016-09-09 11:31:22,684][INFO ][indices.store ] [XXXX] updating indices.store.throttle.type from [NONE] to [none]
[2016-09-09 11:31:22,684][INFO ][indices.store ] [XXXX] updating indices.store.throttle.max_bytes_per_sec from [10gb] to [100mb], note, type is [none]

But as per docs, they are automatically managed / deprecated:
https://www.elastic.co/guide/en/elasticsearch/reference/2.4/breaking_20_setting_changes.html#_merge_and_merge_throttling_settings

When I look at cluster settings I have a transient setting about max_bytes_per_sec.

{
  "transient" : {
    "indices" : {
      "store" : {
        "throttle" : {
          "type" : "none",
          "max_bytes_per_sec" : "100mb"
        }
      }
    }
  }
}

Is this really affecting our potential performance that we can achieve with our SSDs?
If yes, how to remove the setting?

For short, I just want to get maximum performance with SSD setup.

Thanks

ES doesn't currently change its behavior based on spins or not, but that may change in the future.

It is annoying that ES can't detect that your RAID 0 of SSDs does not spin. On Linux, ES (well, Lucene) is peeking at the /sys/block/XXX/queue/rotational file.

That transient setting is actually harmless, since the throttle type is none, the 100mb is doing nothing.

Just let ES/Lucene's auto merge IO throttling run and you should see good performance.

And follow the other tips in https://www.elastic.co/blog/performance-indexing-2-0