ES 5.5.0 java version error on Windows 7


(Ramon) #1

Hi, I tried to test-run ES on a win7 machine which threw up an error re: javaversionchecker, that my java was not version 8 or higher. (it is)

I tried again immediately and it was up and running; I could ingest files through fscrawler and access them through kibana.
however, after shutting off ES et al I have never been able to run it again, I have checked (and re-checked) JAVA_HOME, hash value for ES to rule out file corruption etc.

I have tried and failed in other win7 PC's as well. the same package is running ok on a win10 machine and a win2012 server.

any ideas what could have gone wrong ?


(Tim Vernum) #2

Please post the first 10 lines from your elasticsearch.log, as well as the exact content of the java version check error you are receiving.

From those we can see what Java version is being picked up by Elasticsearch and why it thinks it is not correct.


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.