ES cannot search for special characters when using wildcard search

Hello,

We are using query_string for a quick search but looks like does not correctly work.

For instance I can find results using:

{
    "query": {
        "query_string": {
            "query": "oleg$qwerty.com",
            "fields": [
                "fullName.search"
            ],
            "minimum_should_match": "100%"
        }
   },
    "size": 10
}

But when I try to use *leg$qwerty.com ES doesn't return results.

Did anyone face this issue before? or can help?

Thank in advacne

Which version of Elasticsearch are you using?

What is the mapping for the field you are searching on?

Have you tried analysing this using the analyze API?

Hello @Christian_Dahlqvist,

ES version - 8.4.3

Mapping is :


image

Yes, i've tried to analyze it, it creates 2 tokens but the difference only in start offset:

Hello @polyfractal ,
I found your pretty clear answer related to this topic Wildcard search does not work - #3 by debasisc

But could you take a look at my issue, maybe you have suggestions on this?

Thanks in advance.