ES dies continuously after upgrade from 2.0.1 to 2.1.0


(Marco Sangalli) #1

Four days ago I upgraded (with apt-get) from 2.0.1. to 2.1.0 my single node elastic search on ubuntu in aws. After the upgrade system continuously die after minutes without any message in the logs. After several probes, I tried it in a new fresh 2.1.0 host, without any results: system crash again!

After I saw that the snapshot/restore are not compatible from 2.1.0 to 2.0.1 I done a full reindex of data in a fresh 2.0.1 ES and now is stable again.

Did you have any suggestion?

Thank you in advance, marco


(Mike Simos) #2

Hi,

I'd recommend you enable DEBUG logging in logging.yml by setting es.logger.level: DEBUG. Then restart Elasticsearch and check the Elasticsearch log file for any errors. I'd also check /var/log/messages for any errors there.


(Marco Sangalli) #3

Hi Mike,

thank you for your reply. I'll try to reproduce the problem on a test system with DEBUG enabled. After 24h rollback to 2.0.1 (without any application changes) the system runs without any problem.


(David Pilato) #4

If you can reproduce it with logs and details, please open an issue for it.


(Marco Sangalli) #5

Hi David,

I'll try. I saw another side effect in these days related with this instability: when I tried to restart ES I had the cpu at 100% and then I had to kill the process with -9. I have the logs for that: http://pastebin.com/S1KqALrn


(system) #6