ES reports 4 nodes but only 3 severs. One node is used twice


(David Montgomery) #1

Hi,

ES is showing 4 nodes but I only have 3. How do I resolve? One
address is used twice
172.31.6.204

{
"ok" : true,
"cluster_name" : "elasticsearch",
"nodes" : {
"Fi5sM17uTku9LJYYDtKglQ" : {
"name" : "Beautiful Dreamer",
"transport_address" : "inet[/172.31.6.204:9301]",
"hostname" : "ip-172-31-6-204",
"version" : "0.90.5",
"http_address" : "inet[/172.31.6.204:9201]"
},
"9K0XXGu1STaXfW0pupkbVg" : {
"name" : "Beetle",
"transport_address" : "inet[/172.31.6.93:9300]",
"hostname" : "ip-172-31-6-93",
"version" : "0.90.5",
"http_address" : "inet[/172.31.6.93:9200]"
},
"HcTcSy1YTR22YkTVy9TrgA" : {
"name" : "Arize",
"transport_address" : "inet[/172.31.12.204:9300]",
"hostname" : "ip-172-31-12-204",
"version" : "0.90.5",
"http_address" : "inet[/172.31.12.204:9200]"
},
"xz7aOp9zQcGinK5iJNrSYQ" : {
"name" : "Obituary",
"transport_address" : "inet[/172.31.6.204:9300]",
"hostname" : "ip-172-31-6-204",
"version" : "0.90.5",
"http_address" : "inet[/172.31.6.204:9200]"
}
}
}

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CACF%2B8rpzOsvWm_SkDyTSRf_O21T%2BnaWnYpGrvAzOSS8ENKH-QA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Mark Walkom) #2

Are you using logstash perhaps?
If not then check the number of ES processes on your .204 node as there
could be two instances running.

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: markw@campaignmonitor.com
web: www.campaignmonitor.com

On 2 August 2014 12:58, David Montgomery davidmontgomery@gmail.com wrote:

Hi,

ES is showing 4 nodes but I only have 3. How do I resolve? One address is used twice
172.31.6.204

{
"ok" : true,
"cluster_name" : "elasticsearch",
"nodes" : {
"Fi5sM17uTku9LJYYDtKglQ" : {
"name" : "Beautiful Dreamer",
"transport_address" : "inet[/172.31.6.204:9301]",
"hostname" : "ip-172-31-6-204",
"version" : "0.90.5",
"http_address" : "inet[/172.31.6.204:9201]"
},
"9K0XXGu1STaXfW0pupkbVg" : {
"name" : "Beetle",
"transport_address" : "inet[/172.31.6.93:9300]",
"hostname" : "ip-172-31-6-93",
"version" : "0.90.5",
"http_address" : "inet[/172.31.6.93:9200]"
},
"HcTcSy1YTR22YkTVy9TrgA" : {
"name" : "Arize",
"transport_address" : "inet[/172.31.12.204:9300]",
"hostname" : "ip-172-31-12-204",
"version" : "0.90.5",
"http_address" : "inet[/172.31.12.204:9200]"
},
"xz7aOp9zQcGinK5iJNrSYQ" : {
"name" : "Obituary",
"transport_address" : "inet[/172.31.6.204:9300]",
"hostname" : "ip-172-31-6-204",
"version" : "0.90.5",
"http_address" : "inet[/172.31.6.204:9200]"
}
}
}

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CACF%2B8rpzOsvWm_SkDyTSRf_O21T%2BnaWnYpGrvAzOSS8ENKH-QA%40mail.gmail.com
https://groups.google.com/d/msgid/elasticsearch/CACF%2B8rpzOsvWm_SkDyTSRf_O21T%2BnaWnYpGrvAzOSS8ENKH-QA%40mail.gmail.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEM624Zw8iscE8%3D-WLNTrjpOSyhMUyUyEsO-5v2c8hu0zpz%2BEQ%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(Luis García Acosta) #3

Paste config, u have 2 processes running in the same box

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/68997619-3ba9-4076-8a8b-bfaa784372f7%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Jörg Prante) #4

This is a client node for sure.

Jörg

On Sat, Aug 2, 2014 at 4:58 AM, David Montgomery davidmontgomery@gmail.com
wrote:

Hi,

ES is showing 4 nodes but I only have 3. How do I resolve? One address is used twice
172.31.6.204

{
"ok" : true,
"cluster_name" : "elasticsearch",
"nodes" : {
"Fi5sM17uTku9LJYYDtKglQ" : {
"name" : "Beautiful Dreamer",
"transport_address" : "inet[/172.31.6.204:9301]",
"hostname" : "ip-172-31-6-204",
"version" : "0.90.5",
"http_address" : "inet[/172.31.6.204:9201]"
},
"9K0XXGu1STaXfW0pupkbVg" : {
"name" : "Beetle",
"transport_address" : "inet[/172.31.6.93:9300]",
"hostname" : "ip-172-31-6-93",
"version" : "0.90.5",
"http_address" : "inet[/172.31.6.93:9200]"
},
"HcTcSy1YTR22YkTVy9TrgA" : {
"name" : "Arize",
"transport_address" : "inet[/172.31.12.204:9300]",
"hostname" : "ip-172-31-12-204",
"version" : "0.90.5",
"http_address" : "inet[/172.31.12.204:9200]"
},
"xz7aOp9zQcGinK5iJNrSYQ" : {
"name" : "Obituary",
"transport_address" : "inet[/172.31.6.204:9300]",
"hostname" : "ip-172-31-6-204",
"version" : "0.90.5",
"http_address" : "inet[/172.31.6.204:9200]"
}
}
}

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CACF%2B8rpzOsvWm_SkDyTSRf_O21T%2BnaWnYpGrvAzOSS8ENKH-QA%40mail.gmail.com
https://groups.google.com/d/msgid/elasticsearch/CACF%2B8rpzOsvWm_SkDyTSRf_O21T%2BnaWnYpGrvAzOSS8ENKH-QA%40mail.gmail.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAKdsXoHzrh_BBYG4WACO1%2BRmLzs6wT4NpVe2G50zjbuLb8tRHQ%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(system) #5